summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2020-06-18 00:58:41 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-22 15:44:08 +0200
commit20b545f76835605143c7b9c337dfe0539c102695 (patch)
treed1a32207f74acb0e20aed95f97e23eac81d0f825 /gnu/packages/bioinformatics.scm
parent3a79adab417f4fab6d9ac2b0f839b8d03ed6bb42 (diff)
downloadguix-patches-20b545f76835605143c7b9c337dfe0539c102695.tar
guix-patches-20b545f76835605143c7b9c337dfe0539c102695.tar.gz
gnu: python-pandas: Update to 1.0.5.
But also keep version 0.25.3 around for packages requiring an earlier versions, as well as version 0.24.2 for a version with python2. * gnu/packages/python-science.scm (python-pandas): Update to 1.0.5. [arguments]: Adapt 'patch-which phase. Add new 'prepare-x phase. Do not delete tests that depend on "moto", they are skipped automatically. [propagated-inputs]: Add python-jinja2. [inputs]: Add xsel and xclip. [native-inputs]: Add xorg-server-for-tests so we can test clipboard support. (python-pandas-0.24): New variable. (python2-pandas): Inherit from python-pandas-0.25. * gnu/packages/bioinformatics.scm (python-biom-format)[propagated-inputs]: Switch to python-pandas-0.25. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 784fff7c09..b24266159b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -943,7 +943,9 @@ Python.")
("python-future" ,python-future)
("python-click" ,python-click)
("python-h5py" ,python-h5py)
- ("python-pandas" ,python-pandas)))
+ ;; FIXME: Upgrade to pandas 1.0 when
+ ;; https://github.com/biocore/biom-format/issues/837 is resolved.
+ ("python-pandas" ,python-pandas-0.25)))
(native-inputs
`(("python-cython" ,python-cython)
("python-pytest" ,python-pytest)