summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-23 14:46:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-23 14:46:49 +0200
commitca962b5ba99c53bb91a2f82a4ecedf27d1e59f44 (patch)
treefc7c84a0042446922e3cb53da9b1576c314e475a /gnu/packages/bioconductor.scm
parentbdbfaf76c96f9efcf1b292b152746b2f8d176076 (diff)
downloadguix-patches-ca962b5ba99c53bb91a2f82a4ecedf27d1e59f44.tar
guix-patches-ca962b5ba99c53bb91a2f82a4ecedf27d1e59f44.tar.gz
gnu: Add r-omnipathr.
* gnu/packages/bioconductor.scm (r-omnipathr): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 062867b2ab..e163d33b11 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -14641,6 +14641,57 @@ with a nested autoregressive correlated error structure for the effect of
interest on transformed methylation proportions.")
(license license:expat)))
+(define-public r-omnipathr
+ (package
+ (name "r-omnipathr")
+ (version "3.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "OmnipathR" version))
+ (sha256
+ (base32 "0rbq3h3cp5dgpy5ifmbnfm6z8w4jv45wjzyl1f4qacgrbyf2l30a"))))
+ (properties `((upstream-name . "OmnipathR")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ `(("r-checkmate" ,r-checkmate)
+ ("r-curl" ,r-curl)
+ ("r-digest" ,r-digest)
+ ("r-dplyr" ,r-dplyr)
+ ("r-httr" ,r-httr)
+ ("r-igraph" ,r-igraph)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-later" ,r-later)
+ ("r-logger" ,r-logger)
+ ("r-magrittr" ,r-magrittr)
+ ("r-progress" ,r-progress)
+ ("r-purrr" ,r-purrr)
+ ("r-rappdirs" ,r-rappdirs)
+ ("r-readr" ,r-readr)
+ ("r-readxl" ,r-readxl)
+ ("r-rlang" ,r-rlang)
+ ("r-stringr" ,r-stringr)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)
+ ("r-tidyselect" ,r-tidyselect)
+ ("r-xml2" ,r-xml2)
+ ("r-yaml" ,r-yaml)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://saezlab.github.io/OmnipathR/")
+ (synopsis "OmniPath web service client and more")
+ (description
+ "This package provides a client for the OmniPath web service and many
+other resources. It also includes functions to transform and pretty print
+some of the downloaded data, functions to access a number of other resources.
+Furthermore, OmnipathR features a close integration with the NicheNet method
+for ligand activity prediction from transcriptomics data.")
+ (license license:expat)))
+
(define-public r-biscuiteer
(package
(name "r-biscuiteer")