summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 17:43:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 17:46:33 +0100
commit3972cfce6a03c8714c2b762b8d573e833efd8aee (patch)
treeae9a882d79ae5bc934e216fa3a1560a3a2fe0b93 /gnu/packages/bioconductor.scm
parent692bce15953994e1c19c464a1d91f5222430a166 (diff)
downloadguix-patches-3972cfce6a03c8714c2b762b8d573e833efd8aee.tar
guix-patches-3972cfce6a03c8714c2b762b8d573e833efd8aee.tar.gz
gnu: Add r-gofuncr.
* gnu/packages/bioconductor.scm (r-gofuncr): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c0f0520ce8..fb7e5a95f3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3383,3 +3383,50 @@ diagnostic plots of fragment size distribution, proportion of mitochondria
reads, nucleosome positioning pattern, and CTCF or other Transcript Factor
footprints.")
(license license:gpl2+)))
+
+(define-public r-gofuncr
+ (package
+ (name "r-gofuncr")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GOfuncR" version))
+ (sha256
+ (base32
+ "021kgcbm8n2yalhzab11cyppwznlkglynnh45wsgy9i2vi2n2znk"))))
+ (properties `((upstream-name . "GOfuncR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-gtools" ,r-gtools)
+ ("r-iranges" ,r-iranges)
+ ("r-mapplots" ,r-mapplots)
+ ("r-rcpp" ,r-rcpp)
+ ("r-vioplot" ,r-vioplot)))
+ (home-page "https://bioconductor.org/packages/GOfuncR/")
+ (synopsis "Gene ontology enrichment using FUNC")
+ (description
+ "GOfuncR performs a gene ontology enrichment analysis based on the
+ontology enrichment software FUNC. GO-annotations are obtained from
+OrganismDb or OrgDb packages (@code{Homo.sapiens} by default); the GO-graph is
+included in the package and updated regularly. GOfuncR provides the standard
+candidate vs background enrichment analysis using the hypergeometric test, as
+well as three additional tests:
+
+@enumerate
+@item the Wilcoxon rank-sum test that is used when genes are ranked,
+@item a binomial test that is used when genes are associated with two counts,
+ and
+@item a Chi-square or Fisher's exact test that is used in cases when genes are
+associated with four counts.
+@end enumerate
+
+To correct for multiple testing and interdependency of the tests, family-wise
+error rates are computed based on random permutations of the gene-associated
+variables. GOfuncR also provides tools for exploring the ontology graph and
+the annotations, and options to take gene-length or spatial clustering of
+genes into account. It is also possible to provide custom gene coordinates,
+annotations and ontologies.")
+ (license license:gpl2+)))