summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-04 23:05:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-04 23:05:01 +0100
commitb4d7689f9255b93b9ea02e01dc490f1416f77782 (patch)
tree82c81af4181d5a31555eb5829ba36e5d1a74f414 /gnu/packages/bioconductor.scm
parentdd7ce8643a28f5d633c5f3124de6be897cd5065f (diff)
parent6d3cff5acacecc240b1d86048e41df3ce26483a5 (diff)
downloadguix-patches-b4d7689f9255b93b9ea02e01dc490f1416f77782.tar
guix-patches-b4d7689f9255b93b9ea02e01dc490f1416f77782.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 9057158cde..ae9d7070c3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1199,3 +1199,32 @@ sequencing data.")
algorithm to segment DNA copy number data and identify genomic regions with
abnormal copy number.")
(license license:gpl2+)))
+
+;; This is a CRAN package, but it uncharacteristically depends on a
+;; Bioconductor package.
+(define-public r-htscluster
+ (package
+ (name "r-htscluster")
+ (version "2.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "HTSCluster" version))
+ (sha256
+ (base32
+ "0wnbfh6hdx8692jilgmv8sys1zm6fqc6mim7vvjhyqlmpm8gm0kg"))))
+ (properties `((upstream-name . "HTSCluster")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-capushe" ,r-capushe)
+ ("r-edger" ,r-edger)
+ ("r-plotrix" ,r-plotrix)))
+ (home-page "https://cran.r-project.org/web/packages/HTSCluster")
+ (synopsis "Clustering high-throughput transcriptome sequencing (HTS) data")
+ (description
+ "This package provides a Poisson mixture model is implemented to cluster
+genes from high-throughput transcriptome sequencing (RNA-seq) data. Parameter
+estimation is performed using either the EM or CEM algorithm, and the slope
+heuristics are used for model selection (i.e., to choose the number of
+clusters).")
+ (license license:gpl3+)))