summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:38:59 +0200
commit043c309d154a69455e0fa7624afa98b912bffb6d (patch)
tree338c2ef5330913a7af0d45939edcced5b4571688 /gnu/packages/bioconductor.scm
parente0c81584ea47ebce218a9ef37accab0889860fc1 (diff)
downloadguix-patches-043c309d154a69455e0fa7624afa98b912bffb6d.tar
guix-patches-043c309d154a69455e0fa7624afa98b912bffb6d.tar.gz
gnu: r-rhtslib: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-rhtslib): Move from here... * gnu/packages/bioconductor.scm (r-rhtslib): ...to here.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ea4e373b49..cb42c0bed2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages cran)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages gcc)
#:use-module (gnu packages graph)
#:use-module (gnu packages graphviz)
@@ -3037,6 +3038,37 @@ Enrichment Analysis} (GSEA).")
the Human Protein Atlas project.")
(license license:artistic2.0)))
+(define-public r-rhtslib
+ (package
+ (name "r-rhtslib")
+ (version "1.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Rhtslib" version))
+ (sha256
+ (base32
+ "18wag2jnpda6078xjkpfdvar1gkb2myhw83gg03l39sabh35qya4"))))
+ (properties `((upstream-name . "Rhtslib")))
+ (build-system r-build-system)
+ ;; Without this a temporary directory ends up in the Rhtslib.so binary,
+ ;; which makes R abort the build.
+ (arguments '(#:configure-flags '("--no-staged-install")))
+ (propagated-inputs
+ `(("curl" ,curl)
+ ("zlib" ,zlib) ; packages using rhtslib need to link with zlib
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/nhayden/Rhtslib")
+ (synopsis "High-throughput sequencing library as an R package")
+ (description
+ "This package provides the HTSlib C library for high-throughput
+nucleotide sequence analysis. The package is primarily useful to developers
+of other R packages who wish to make use of HTSlib.")
+ (license license:lgpl2.0+)))
+
(define-public r-impute
(package
(name "r-impute")