summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:39:49 +0200
commit7ab44aeed61b1e0a3a048bf2b991180d76a97aff (patch)
tree93545f7760d767af3ad27b2b3780689277a6caf1 /gnu/packages/bioconductor.scm
parent36cb01066cc03b2d341b55f21ebba2156518a560 (diff)
downloadguix-patches-7ab44aeed61b1e0a3a048bf2b991180d76a97aff.tar
guix-patches-7ab44aeed61b1e0a3a048bf2b991180d76a97aff.tar.gz
gnu: r-copywriter: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-copywriter): Move from here... * gnu/packages/bioconductor.scm (r-copywriter): ...to here.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 9118642e66..fae6073446 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2500,6 +2500,46 @@ provides a highly flexible way to arrange multiple heatmaps and supports
self-defined annotation graphics.")
(license license:gpl2+)))
+(define-public r-copywriter
+ (package
+ (name "r-copywriter")
+ (version "2.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "CopywriteR" version))
+ (sha256
+ (base32
+ "060p6l6l8i6b15hyyz5v5kkxih3h4wcciixii51m9mn82z23xr2f"))))
+ (properties `((upstream-name . "CopywriteR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocparallel" ,r-biocparallel)
+ ("r-chipseq" ,r-chipseq)
+ ("r-copyhelper" ,r-copyhelper)
+ ("r-data-table" ,r-data-table)
+ ("r-dnacopy" ,r-dnacopy)
+ ("r-futile-logger" ,r-futile-logger)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-gtools" ,r-gtools)
+ ("r-iranges" ,r-iranges)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "https://github.com/PeeperLab/CopywriteR")
+ (synopsis "Copy number information from targeted sequencing")
+ (description
+ "CopywriteR extracts DNA copy number information from targeted sequencing
+by utilizing off-target reads. It allows for extracting uniformly distributed
+copy number information, can be used without reference, and can be applied to
+sequencing data obtained from various techniques including chromatin
+immunoprecipitation and target enrichment on small gene panels. Thereby,
+CopywriteR constitutes a widely applicable alternative to available copy
+number detection tools.")
+ (license license:gpl2)))
+
(define-public r-deseq
(package
(name "r-deseq")