summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-31 17:51:30 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:32 +0200
commite4721f7472ba9bc1d025a52edc96a568e9b574b8 (patch)
treea53c9322fe76a1a16915f65ce79287ae3c44e657 /gnu/packages/base.scm
parent360c8873ff693297a6a30c8142ec5698e05edf99 (diff)
downloadguix-patches-e4721f7472ba9bc1d025a52edc96a568e9b574b8.tar
guix-patches-e4721f7472ba9bc1d025a52edc96a568e9b574b8.tar.gz
gnu: coreutils: Skip hanging and failing test on the Hurd.
* gnu/packages/base.scm (coreutils)[arguments]: When building natively on the Hurd, remove "test/df/unreadable.sh" and "test-perror2" from #:make-flags's XFAIL_TESTS as they now pass. Move failing script tests from XFAIL_TESTS to 'remove-tests' phase. In phase 'remove-tests' rewrite substitute* to skip tests instead of removing them. Add hanging and failing tests.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm47
1 files changed, 31 insertions, 16 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 55fe70309c..e941853d20 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -397,23 +397,13 @@ used to apply commands with arbitrarily long arguments.")
(outputs '("out" "debug"))
(arguments
`(#:parallel-build? #f ; help2man may be called too early
- ,@(if (target-hurd?)
+ ,@(if (system-hurd?)
'(#:make-flags ; these tests fail deterministically
- (list (string-append "XFAIL_TESTS=tests/misc/env-S.pl"
- " tests/misc/kill.sh"
- " tests/misc/nice.sh"
- " tests/misc/pwd-long.sh"
- " tests/split/fail.sh"
-
- ;; /hurd/fifo issue:
- ;; <https://issues.guix.gnu.org/58803>.
- " tests/df/unreadable.sh"
-
+ (list (string-append "XFAIL_TESTS="
;; Gnulib tests.
" test-fdutimensat"
" test-futimens"
" test-linkat"
- " test-perror2"
" test-renameat"
" test-renameatu"
" test-utimensat")))
@@ -435,10 +425,35 @@ used to apply commands with arbitrarily long arguments.")
(("#!/bin/sh") (string-append "#!" (which "sh"))))))
(add-after 'unpack 'remove-tests
(lambda _
- ,@(if (target-hurd?)
- '((substitute* "Makefile.in"
- ;; this test hangs
- (("^ *tests/misc/timeout-group.sh.*") ""))
+ ,@(if (system-hurd?)
+ '((substitute*
+ ;; These tests hang
+ '("tests/cp/sparse-to-pipe.sh"
+ "tests/split/fail.sh"
+ ;; These tests error
+ "tests/dd/nocache.sh"
+ ;; These tests fail
+ "tests/cp/sparse.sh"
+ "tests/cp/special-f.sh"
+ "tests/dd/bytes.sh"
+ "tests/dd/stats.sh"
+ "tests/ls/dangle.sh"
+ "tests/ls/follow-slink.sh"
+ "tests/ls/hyperlink.sh"
+ "tests/ls/infloop.sh"
+ "tests/ls/inode.sh"
+ "tests/ls/selinux-segfault.sh"
+ "tests/misc/env-S.pl"
+ "tests/misc/factor-parallel.sh"
+ "tests/misc/ls-misc.pl"
+ "tests/misc/nice.sh"
+ "tests/misc/pwd-long.sh"
+ "tests/misc/shred-passes.sh"
+ "tests/misc/stat-slash.sh"
+ "tests/rm/fail-eperm.xpl"
+ "tests/split/filter.sh")
+ (("^#!.*" all)
+ (string-append all "exit 77;\n")))
(substitute* "gnulib-tests/Makefile.in"
;; This test sometimes fails and sometimes
;; passes, but it does this consistently, so