summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-10 11:25:09 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-10 11:25:09 +0200
commitbbe032940c1ba4dd4aa0e450b288f7aca1588d90 (patch)
treeab3a655136a4d1f6d94b5fa86a95cfb85eaa7e20 /gnu/packages/base.scm
parent99865f6e863c64978379ff5bc741824df61a1614 (diff)
downloadguix-patches-bbe032940c1ba4dd4aa0e450b288f7aca1588d90.tar
guix-patches-bbe032940c1ba4dd4aa0e450b288f7aca1588d90.tar.gz
gnu: tar: Allow cross-compilation.
* gnu/packages/base.scm (tar)[inputs]: New field.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 502684ff40..422424cbe8 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -160,6 +160,13 @@ implementation offers several extensions over the standard utility.")
(("/bin/sh")
(string-append bash "/bin/sh")))
#t))))))
+
+ ;; When cross-compiling, the 'set-shell-file-name' phase needs to be able
+ ;; to refer to the target Bash.
+ (inputs (if (%current-target-system)
+ `(("bash" ,bash))
+ '()))
+
(synopsis "Managing tar archives")
(description
"Tar provides the ability to create tar archives, as well as the