summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-16 23:14:28 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-16 23:14:28 +0100
commit13990c7343b93190716edb967ecd0159ddc1b6d9 (patch)
tree0f0469ec5ba749cfdabdd191bad0b987f06b879a /gnu/packages/base.scm
parent127ed6a9ddcaaec56e88b717892e74e3840584ef (diff)
downloadguix-patches-13990c7343b93190716edb967ecd0159ddc1b6d9.tar
guix-patches-13990c7343b93190716edb967ecd0159ddc1b6d9.tar.gz
gnu: glibc: Really disable 'ldconfig' and /etc/ld.so.cache.
* gnu/packages/base.scm (glibc): Add 'snippet' to set use_ldconfig=no. Remove "glibc-no-ld-so-cache.patch"; that patch would still build 'ldconfig', and ld.so would still contain ld.so.cache-related code, and would look for info in /etc/etc/ld.so.cache (sic). * gnu/packages/patches/glibc-no-ld-so-cache.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 0fa7b3f137..d32f617ceb 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -365,9 +365,17 @@ archives.")
(sha256
(base32
"18spla703zav8dq9fw7rbzkyv9qfisxb26p7amg1x3wjh7iy3d1c"))
+ (snippet
+ ;; Disable 'ldconfig' and /etc/ld.so.cache. The latter is
+ ;; required on LFS distros to avoid loading the distro's libc.so
+ ;; instead of ours.
+ '(substitute* "sysdeps/unix/sysv/linux/configure"
+ (("use_ldconfig=yes")
+ "use_ldconfig=no")))
+ (modules '((guix build utils)))
+ (imported-modules modules)
(patches (map search-patch
- '("glibc-no-ld-so-cache.patch"
- "glibc-ldd-x86_64.patch"
+ '("glibc-ldd-x86_64.patch"
"glibc-make-4.0.patch")))))
(build-system gnu-build-system)