summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-09-08 11:05:45 -0400
committerMark H Weaver <mhw@netris.org>2014-09-08 11:27:05 -0400
commit39ccbfad1c1b56c4866563a60676cb35b6a17871 (patch)
treebe09bf53cb5eafdad46541c62ab9486a8071798f /gnu/packages/base.scm
parente759c0a38c799f2d03b3454e9ca6acf2262dc957 (diff)
downloadguix-patches-39ccbfad1c1b56c4866563a60676cb35b6a17871.tar
guix-patches-39ccbfad1c1b56c4866563a60676cb35b6a17871.tar.gz
gnu: glibc: Update to 2.20.
* gnu/packages/patches/glibc-CVE-2014-5119.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/base.scm (glibc): Update to 2.20. Remove patch. Raise minimum linux version to 2.6.32.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index cbe115f8a8..5ecff76252 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -357,14 +357,14 @@ library for working with executable and object formats is also included.")
(define-public glibc
(package
(name "glibc")
- (version "2.19")
+ (version "2.20")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/glibc/glibc-"
version ".tar.xz"))
(sha256
(base32
- "18m2dssd6ja5arxmdxinc90xvpqcsnqjfwmjl2as07j0i3srff9d"))
+ "19bbyfc2gcxr9rihrkkbd3p362i608yhlyrr7icqsa6cmr16sjzq"))
(snippet
;; Disable 'ldconfig' and /etc/ld.so.cache. The latter is
;; required on LFS distros to avoid loading the distro's libc.so
@@ -373,8 +373,7 @@ library for working with executable and object formats is also included.")
(("use_ldconfig=yes")
"use_ldconfig=no")))
(modules '((guix build utils)))
- (patches (list (search-patch "glibc-CVE-2014-5119.patch")
- (search-patch "glibc-ldd-x86_64.patch")))))
+ (patches (list (search-patch "glibc-ldd-x86_64.patch")))))
(build-system gnu-build-system)
;; Glibc's <limits.h> refers to <linux/limit.h>, for instance, so glibc
@@ -405,10 +404,10 @@ library for working with executable and object formats is also included.")
(assoc-ref %build-inputs "linux-headers")
"/include")
- ;; The default is to assume a 2.4 Linux interface, but we'll
- ;; always use something newer. See "kernel-features.h" in the
- ;; GNU libc for details.
- "--enable-kernel=2.6.30"
+ ;; This is the default for most architectures as of GNU libc 2.20,
+ ;; but we specify it explicitly for clarity and consistency. See
+ ;; "kernel-features.h" in the GNU libc for details.
+ "--enable-kernel=2.6.32"
;; Use our Bash instead of /bin/sh.
(string-append "BASH_SHELL="