summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2016-09-14 00:07:42 +1000
committerEric Bavier <bavier@member.fsf.org>2016-09-15 22:39:31 -0500
commitf6875394a6dce98c78c3d4f222f6f9bc4d5402aa (patch)
treeae96336da6b34e3a3bf252bc321f9e76e4cb208b /gnu/packages/backup.scm
parent7f39e131805857614a171b51cbf432b4285ba1e6 (diff)
downloadguix-patches-f6875394a6dce98c78c3d4f222f6f9bc4d5402aa.tar
guix-patches-f6875394a6dce98c78c3d4f222f6f9bc4d5402aa.tar.gz
gnu: Add par2cmdline.
* gnu/packages/backup.scm (par2cmdline): New variable.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 4678b9b91f..e77c4f20a9 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -28,6 +28,7 @@
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages acl)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
@@ -99,6 +100,42 @@ uses GnuPG to encrypt and/or sign these archives, they will be safe from
spying and/or modification by the server.")
(license license:gpl2+)))
+(define-public par2cmdline
+ (package
+ (name "par2cmdline")
+ (version "0.6.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Parchive/par2cmdline/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ykfb7ar0x0flfdgf6i8xphyv5b93dalbjj2jb6hx7sdjax33n1g"))
+ ;; This test merely needs a file to test recovery on, but
+ ;; /dev/random is essentially /dev/urandom plus minimum entropy
+ ;; locking, making the test hang indefinitely. This change is
+ ;; already upstream: remove on upgrade to future 0.6.15.
+ ;; https://github.com/Parchive/par2cmdline/commit/27723a678f780da82c79b98592592009c779a4fb
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "tests/test20" (("if=/dev/random") "if=/dev/urandom")))))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autoreconf
+ (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
+ (synopsis "File verification and repair tool")
+ (description "Par2cmdline is a tool for generating RAID-like PAR2 recovery
+files using Reed-Solomon coding. PAR2 files can be stored along side backups
+or distributed files for recovering from bitrot.")
+ (home-page "https://github.com/Parchive/par2cmdline")
+ (license license:gpl3+)))
+
(define-public hdup
(package
(name "hdup")