summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-03-09 11:49:24 -0500
committerTimothy Sample <samplet@ngyro.com>2021-03-22 22:18:29 -0400
commitca5420d3b27dcefa9ada704db0d694ff62238b73 (patch)
tree3f428ac0c44918a105f91b9f0e6799b3e3ef0952 /gnu/packages/backup.scm
parent897177c98e62ef53af52aeafc349c9e858b41389 (diff)
downloadguix-patches-ca5420d3b27dcefa9ada704db0d694ff62238b73.tar
guix-patches-ca5420d3b27dcefa9ada704db0d694ff62238b73.tar.gz
gnu: Add disarchive.
* gnu/packages/backup.scm (disarchive): New variable.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 78c5b31bb5..860e1abe23 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Timothy Sample <samplet@ngyro.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,6 +63,7 @@
#:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages guile-xyz)
#:use-module (gnu packages linux)
#:use-module (gnu packages mcrypt)
#:use-module (gnu packages ncurses)
@@ -1083,3 +1085,35 @@ interactive mode.")
to reduce network traffic and the amount of space that is used by each
backup.")
(license license:agpl3)))
+
+(define-public disarchive
+ (package
+ (name "disarchive")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://files.ngyro.com/disarchive/"
+ "disarchive-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12d4r4i7vi8fxilr2aww6kzq56jax5ymhjfm3cpgx26vj4c70kb6"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("guile-quickcheck" ,guile-quickcheck)))
+ (inputs
+ `(("guile" ,guile-3.0)
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ `(("guile-gcrypt" ,guile-gcrypt)))
+ (home-page "https://ngyro.com/software/disarchive.html")
+ (synopsis "Software archive disassembler")
+ (description "Disarchive can disassemble software archives into data
+and metadata. The goal is to create a small amount of metadata that
+can be used to recreate a software archive bit-for-bit from the
+original files. For example, a software archive made using tar and
+Gzip will need to describe the order of files in the tarball and the
+compression parameters used by Gzip.")
+ (license license:gpl3+)))