summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 21:56:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:17:00 +0200
commite252ec324d3bb79cb411bd1682c215792f5c8001 (patch)
tree24f15a17a0c4a47113bd4fa5485c6ccaa2b8dd6e /gnu/packages/backup.scm
parent4ce7c1b35386e3d7b85e9b80414bab19ca798ba8 (diff)
downloadguix-patches-e252ec324d3bb79cb411bd1682c215792f5c8001.tar
guix-patches-e252ec324d3bb79cb411bd1682c215792f5c8001.tar.gz
gnu: borg: Return #t from all phases.
* gnu/packages/backup.scm (borg)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined from phases.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm45
1 files changed, 21 insertions, 24 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index f781dc1813..de96e6af21 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -523,25 +523,24 @@ detection, and lossless compression.")
;; The tests should be run in an empty directory.
(mkdir-p "tests")
(with-directory-excursion "tests"
- (zero?
- (system* "py.test" "-v" "--pyargs" "borg.testsuite" "-k"
- (string-append
- ;; These tests need to write to '/var'.
- "not test_get_cache_dir "
- "and not test_get_config_dir "
- "and not test_get_keys_dir "
- "and not test_get_security_dir "
- ;; These tests assume there is a root user in
- ;; '/etc/passwd'.
- "and not test_access_acl "
- "and not test_default_acl "
- "and not test_non_ascii_acl "
- ;; This test needs the unpackaged pytest-benchmark.
- "and not benchmark "
- ;; These tests assume the kernel supports FUSE.
- "and not test_fuse "
- "and not test_fuse_allow_damaged_files "
- "and not test_mount_hardlinks"))))))
+ (invoke "py.test" "-v" "--pyargs" "borg.testsuite" "-k"
+ (string-append
+ ;; These tests need to write to '/var'.
+ "not test_get_cache_dir "
+ "and not test_get_config_dir "
+ "and not test_get_keys_dir "
+ "and not test_get_security_dir "
+ ;; These tests assume there is a root user in
+ ;; '/etc/passwd'.
+ "and not test_access_acl "
+ "and not test_default_acl "
+ "and not test_non_ascii_acl "
+ ;; This test needs the unpackaged pytest-benchmark.
+ "and not benchmark "
+ ;; These tests assume the kernel supports FUSE.
+ "and not test_fuse "
+ "and not test_fuse_allow_damaged_files "
+ "and not test_mount_hardlinks")))))
(add-after 'install 'install-doc
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -552,11 +551,9 @@ detection, and lossless compression.")
"docs/misc/internals-picture.txt"
"docs/misc/prune-example.txt"))
(add-installed-pythonpath inputs outputs)
- (and
- (zero? (system* "python3" "setup.py" "build_man"))
- (begin
- (copy-recursively "docs/man" man)
- #t))))))))
+ (invoke "python3" "setup.py" "build_man")
+ (copy-recursively "docs/man" man)
+ #t))))))
(native-inputs
`(("python-cython" ,python-cython)
("python-setuptools-scm" ,python-setuptools-scm)