summaryrefslogtreecommitdiff
path: root/gnu/packages/aux-files
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-18 18:25:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-12-20 12:52:51 +0200
commit53b51b44fd2dd4f56792ea4fc31dac55dd9558e4 (patch)
tree5e2e24cc50e0e0dd1ffaa476491fbaa00c4157e9 /gnu/packages/aux-files
parentcaee6ec7c8c9ce7ef1e90963190396cda1f6ad4c (diff)
downloadguix-patches-53b51b44fd2dd4f56792ea4fc31dac55dd9558e4.tar
guix-patches-53b51b44fd2dd4f56792ea4fc31dac55dd9558e4.tar.gz
gnu: vim: Automatically find vim plugins.
* gnu/packages/vim.scm (vim)[arguments]: Add new 'install-guix.vim phase to install vendor specific vimrc. * gnu/packages/aux-files/guix.vim: New file. * Makefile.am (AUX_FILES): Register it.
Diffstat (limited to 'gnu/packages/aux-files')
-rw-r--r--gnu/packages/aux-files/guix.vim7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/aux-files/guix.vim b/gnu/packages/aux-files/guix.vim
new file mode 100644
index 0000000000..7dc359e52b
--- /dev/null
+++ b/gnu/packages/aux-files/guix.vim
@@ -0,0 +1,7 @@
+" This appends all of the vim plugins to the end of Vim's runtimepath.
+for directory in ["/run/current-system/profile", $HOME . "/.guix-profile", $GUIX_PROFILE, $GUIX_ENVIRONMENT]
+ let vimplugins = directory . "/share/vim/vimfiles"
+ if isdirectory(vimplugins)
+ let &rtp = join([&rtp,vimplugins], ',')
+ endif
+endfor