summaryrefslogtreecommitdiff
path: root/gnu/packages/aux-files/run-in-namespace.c
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-24 17:28:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-24 17:28:11 +0200
commitc57d649de380da890f296428b85564cbc527bbad (patch)
tree79e9c0b5407aea91c421f7004a0da7bb1e207ba4 /gnu/packages/aux-files/run-in-namespace.c
parent69c2e0103ab64aa6e0beb7651797de9cfd22a6d7 (diff)
parent9b42918edd3f7e9d505c874d3947c0a0815fe551 (diff)
downloadguix-patches-c57d649de380da890f296428b85564cbc527bbad.tar
guix-patches-c57d649de380da890f296428b85564cbc527bbad.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/aux-files/run-in-namespace.c')
-rw-r--r--gnu/packages/aux-files/run-in-namespace.c10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/aux-files/run-in-namespace.c b/gnu/packages/aux-files/run-in-namespace.c
index 551f4db88a..160f7da1c8 100644
--- a/gnu/packages/aux-files/run-in-namespace.c
+++ b/gnu/packages/aux-files/run-in-namespace.c
@@ -1,5 +1,5 @@
/* GNU Guix --- Functional package management for GNU
- Copyright (C) 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+ Copyright (C) 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
This file is part of GNU Guix.
@@ -343,7 +343,13 @@ Please refer to the 'guix pack' documentation for more information.\n");
chdir ("/"); /* avoid EBUSY */
rm_rf (new_root);
free (new_root);
- exit (status);
+
+ if (WIFEXITED (status))
+ exit (WEXITSTATUS (status));
+ else
+ /* Abnormal termination cannot really be reproduced, so exit
+ with 255. */
+ exit (255);
}
}
}