summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-11 08:58:37 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-11 09:03:44 +0200
commit705ddc6a4f2dcb53e3dd046153e684723b284163 (patch)
tree509f1bc53d2fe3bf84e446f2caad67d23409157c /gnu/packages/autotools.scm
parent741a587958ff0448f23c775ebd7667d2160a496a (diff)
downloadguix-patches-705ddc6a4f2dcb53e3dd046153e684723b284163.tar
guix-patches-705ddc6a4f2dcb53e3dd046153e684723b284163.tar.gz
gnu: automake: Fix cross-build.
This is a follow-up to commit ea908c1c04804e51dbd156981c21d8397367d40d gnu: automake: Remove input labels. * gnu/packages/autotools.scm (automake)[arguments]: Use "#~" instead of "'".
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 37a64676a8..fc6bb196f1 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -369,29 +369,29 @@ output is indexed in many ways to simplify browsing.")
(string-append "exit 77\n" all "\n")))))
#$@(if (%current-target-system)
- '((add-after 'install 'patch-non-shebang-references
- (lambda* (#:key inputs #:allow-other-keys)
- ;; `patch-shebangs' patches shebangs only, and the Perl
- ;; scripts use a re-exec feature that references the
- ;; build hosts' perl. Also, AUTOCONF and BASH store
- ;; references hide in the scripts.
- (let ((autoconf
- (dirname (dirname
- (search-input-file inputs "bin/autoconf"))))
- (bash
- (dirname (dirname
- (search-input-file inputs "bin/bash"))))
- (perl
- (dirname (dirname
- (search-input-file inputs "bin/perl"))))
- (store-directory (%store-directory)))
- (substitute* (find-files (string-append #$output "/bin"))
- (((string-append store-directory "/[^/]*-autoconf-[^/]*"))
- autoconf)
- (((string-append store-directory "/[^/]*-bash-[^/]*"))
- bash)
- (((string-append store-directory "/[^/]*-perl-[^/]*"))
- perl))))))
+ #~((add-after 'install 'patch-non-shebang-references
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; `patch-shebangs' patches shebangs only, and the Perl
+ ;; scripts use a re-exec feature that references the
+ ;; build hosts' perl. Also, AUTOCONF and BASH store
+ ;; references hide in the scripts.
+ (let ((autoconf
+ (dirname (dirname
+ (search-input-file inputs "bin/autoconf"))))
+ (bash
+ (dirname (dirname
+ (search-input-file inputs "bin/bash"))))
+ (perl
+ (dirname (dirname
+ (search-input-file inputs "bin/perl"))))
+ (store-directory (%store-directory)))
+ (substitute* (find-files (string-append #$output "/bin"))
+ (((string-append store-directory "/[^/]*-autoconf-[^/]*"))
+ autoconf)
+ (((string-append store-directory "/[^/]*-bash-[^/]*"))
+ bash)
+ (((string-append store-directory "/[^/]*-perl-[^/]*"))
+ perl))))))
'())
;; Files like `install-sh', `mdate.sh', etc. must use