summaryrefslogtreecommitdiff
path: root/gnu/packages/autogen.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:53:16 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:53:16 +0200
commit091eb323ba2787ce64a1fb2796e7e06dbee6037c (patch)
tree446a869245541bd48f303caef76e4c24f6e7d0bb /gnu/packages/autogen.scm
parent05fef7bfc60058763f5a64ec0feaf3876b56281d (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
downloadguix-patches-091eb323ba2787ce64a1fb2796e7e06dbee6037c.tar
guix-patches-091eb323ba2787ce64a1fb2796e7e06dbee6037c.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/autogen.scm')
-rw-r--r--gnu/packages/autogen.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
index 7213776f07..d0c8df17ec 100644
--- a/gnu/packages/autogen.scm
+++ b/gnu/packages/autogen.scm
@@ -62,6 +62,10 @@
#:phases
(modify-phases %standard-phases
+ (add-before 'build 'set-man-page-date
+ ;; Avoid embedding the current date for reproducible builds
+ (lambda _
+ (setenv "MAN_PAGE_DATE" "2012-04-18")))
(add-before 'patch-source-shebangs 'patch-test-scripts
(lambda _
(let ((sh (which "sh")))