summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-29 09:26:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-03-29 09:26:10 +0300
commit5a4d0a653146442f9a17ebf1485dd89e8ab84dc4 (patch)
treeb6805574f54b07a46452989c3f6b71e5170791a9 /gnu/packages/audio.scm
parenta99932503ebcc8190034de8489f9d2036cd453f6 (diff)
downloadguix-patches-5a4d0a653146442f9a17ebf1485dd89e8ab84dc4.tar
guix-patches-5a4d0a653146442f9a17ebf1485dd89e8ab84dc4.tar.gz
gnu: wavpack: Update to 5.4.0.
* gnu/packages/audio.scm (wavpack): Update to 5.4.0. [source]: Download release tarball. [arguments]: Remove custom 'boostrap phase. [native-inputs]: Remove autoconf, automake, libtool.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm25
1 files changed, 6 insertions, 19 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 29ef0266ce..badeecd7b0 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3259,31 +3259,18 @@ stretching and pitch scaling of audio. This package contains the library.")
(define-public wavpack
(package
(name "wavpack")
- (version "5.3.2")
+ (version "5.4.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dbry/WavPack")
- (commit "e4e8d191e8dd74cbdbeaef3232c16a7ef517e68d")))
+ (method url-fetch)
+ (uri (string-append "https://github.com/dbry/WavPack/releases/download/"
+ version "/wavpack-" version ".tar.xz"))
(sha256
- (base32 "1zj8svk6giy1abq3940sz32ygz7zldppxl47852zgn5wfm3l2spx"))
- (file-name (git-file-name name version))))
+ (base32 "0ycbqarw25x7208jilh86vwwiqklr7f617jps9mllqc659mnmpjb"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
- (list "--disable-static")
- #:phases
- (modify-phases %standard-phases
- (replace 'bootstrap
- ;; Running ./autogen.sh would cause premature configuration.
- (lambda _
- (invoke "autoreconf" "-vif")
- #t)))))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list "--disable-static")))
(home-page "https://www.wavpack.com/")
(synopsis "Hybrid lossless audio codec")
(description