summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-14 09:41:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-14 09:43:37 +0100
commit9f3cb56038392e76c001d3da4176d5363186871a (patch)
tree004eed7e63f714ccab6efb97c2ee086488a1ceb8 /gnu/packages/audio.scm
parent41807eb5329299b8c45cd49356a4ead01ce0d469 (diff)
downloadguix-patches-9f3cb56038392e76c001d3da4176d5363186871a.tar
guix-patches-9f3cb56038392e76c001d3da4176d5363186871a.tar.gz
gnu: alsa-modular-synth: Update to 2.2.0.
* gnu/packages/audio.scm (alsa-modular-synth): Update to 2.2.0. [arguments]: Remove them all. [source]: Remove patch. [native-inputs]: Remove gcc@5. * gnu/packages/patches/alsa-modular-synth-fix-vocoder.patch: Remove it. * gnu/local.mk (dist_patch_DATA): Remove patch.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm33
1 files changed, 3 insertions, 30 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 7a5dfe0223..4acc345c3e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -476,41 +476,15 @@ implementation of Adaptive Multi Rate Narrowband and Wideband
(define-public alsa-modular-synth
(package
(name "alsa-modular-synth")
- (version "2.1.2")
+ (version "2.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/alsamodular/alsamodular"
"/" version "/ams-" version ".tar.bz2"))
(sha256
(base32
- "1azbrhpfk4nnybr7kgmc7w6al6xnzppg853vas8gmkh185kk11l0"))
- (patches
- (search-patches "alsa-modular-synth-fix-vocoder.patch"))))
+ "056dn6b9c5nsw2jdww7z1kxrjqqfvxjzxhsd5x9gi4wkwyiv21nz"))))
(build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- '("--enable-qt5"
- "CXXFLAGS=-std=gnu++11")
- #:phases
- (modify-phases %standard-phases
- (add-after 'set-paths 'hide-default-gcc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((gcc (assoc-ref inputs "gcc")))
- ;; Remove the default GCC from CPLUS_INCLUDE_PATH to prevent
- ;; conflicts with the GCC 5 input.
- (setenv "CPLUS_INCLUDE_PATH"
- (string-join
- (delete (string-append gcc "/include/c++")
- (string-split (getenv "CPLUS_INCLUDE_PATH") #\:))
- ":"))
- #t)))
- ;; Insert an extra space between linker flags.
- (add-before 'configure 'add-missing-space
- (lambda _
- (substitute* "configure"
- (("LIBS\\+=\\$LIBSsave") "LIBS+=\" $LIBSsave\"")
- (("CFLAGS\\+=\\$CFLAGSsave") "CFLAGS+=\" $CFLAGSsave\""))
- #t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
;; We cannot use zita-alsa-pcmi (the successor of clalsadrv) due to
@@ -523,8 +497,7 @@ implementation of Adaptive Multi Rate Narrowband and Wideband
("qtbase" ,qtbase)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("qttools" ,qttools)
- ("gcc@5" ,gcc-5)))
+ ("qttools" ,qttools)))
(home-page "http://alsamodular.sourceforge.net/")
(synopsis "Realtime modular synthesizer and effect processor")
(description