summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-09 15:28:17 +0000
committerLeo Famulari <leo@famulari.name>2021-10-16 17:32:24 -0400
commit9fe7b55ad075bbb415667cc40c515b8935e20353 (patch)
tree1fc9b572fc201417d609df62033ece119c6053cb /gnu/packages/audio.scm
parent87535cbc9876295fac84c1c5be6a2ec1f72e96fb (diff)
downloadguix-patches-9fe7b55ad075bbb415667cc40c515b8935e20353.tar
guix-patches-9fe7b55ad075bbb415667cc40c515b8935e20353.tar.gz
gnu: Add libshout-idjc.
* gnu/packages/audio.scm (libshout-idjc): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 4712e9aa72..a8764f99f4 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3089,6 +3089,31 @@ for \"realtime\" in the index of the Guix manual to learn how to achieve this
using Guix System.")
(license license:gpl2+)))
+(define-public libshout-idjc
+ (package
+ (name "libshout-idjc")
+ (version "2.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/libshoutidjc.idjc.p"
+ "/libshout-idjc-" version ".tar.gz"))
+ (sha256
+ (base32 "1r9z8ggxylr2ab0isaljbm574rplnlcb12758j994h54nh2vikwb"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libogg" ,libogg)
+ ("libtheora" ,libtheora)
+ ("libvorbis" ,libvorbis)
+ ("speex" ,speex)))
+ (home-page "http://idjc.sourceforge.net/")
+ (synopsis "Broadcast streaming library with IDJC extensions")
+ (description "This package provides libshout plus IDJC extensions.")
+ ;; GNU Library (not Lesser) General Public License.
+ (license license:lgpl2.0+)))
+
(define-public raul
(package
(name "raul")