summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-07-08 22:43:14 +0100
committerMarius Bakke <marius@gnu.org>2020-07-21 00:58:03 +0200
commit8aca4f69d6a94c318cb7c6b9bd81b91eefe65797 (patch)
treeef78b1194e4c31d7f21074ce70327522b109c235 /gnu/packages/audio.scm
parent7b866af58ccb0c1de5c3d28ced5885e599206c15 (diff)
downloadguix-patches-8aca4f69d6a94c318cb7c6b9bd81b91eefe65797.tar
guix-patches-8aca4f69d6a94c318cb7c6b9bd81b91eefe65797.tar.gz
gnu: Add ttaenc.
* gnu/packages/audio.scm (ttaenc): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 080261a5ca..dfef3a81e7 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4074,6 +4074,45 @@ stream to one or more IceCast and/or ShoutCast servers.")
(home-page "https://x42.github.io/libltc/")
(license license:lgpl3+)))
+(define-public ttaenc
+ (package
+ (name "ttaenc")
+ (version "3.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/tta/"
+ "tta/ttaenc-src"
+ "/ttaenc-" version "-src.tgz"))
+ (sha256
+ (base32
+ "1iixpr4b89g9g1hwn8ak8k8iflcww3r5f09a117qdidc2nqcijdj"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "INSDIR=" (assoc-ref %outputs "out") "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (add-before 'install 'make-bindir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ #t))))))
+ (synopsis "TTA lossless audio encoder")
+ (description
+ "TTA performs lossless compression on multichannel 8,16 and 24 bits
+data of the Wav audio files. Being lossless means that no data-
+quality is lost in the compression - when uncompressed, the data will
+be identical to the original. The compression ratios of TTA depend on
+the type of music file being compressed, but the compression size
+will generally range between 30% - 70% of the original. TTA format
+supports both of ID3v1/v2 and APEv2 tags.")
+ (home-page "http://tausoft.org/")
+ (license license:gpl2+)))
+
(define-public redkite
(package
(name "redkite")