summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-15 22:45:05 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-16 09:42:34 +0200
commitd474052b9515c5ea048c9e29a1c636843eac41cf (patch)
treedffbf7850458b213ad77939013b73ea877c6d94e /gnu/packages/audio.scm
parent7294cbecdd89156c6c651f30ad4c29ad051b46d9 (diff)
downloadguix-patches-d474052b9515c5ea048c9e29a1c636843eac41cf.tar
guix-patches-d474052b9515c5ea048c9e29a1c636843eac41cf.tar.gz
gnu: Add libinstpatch.
* gnu/packages/audio.scm (libinstpatch): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8a74d68fee..37eca6c291 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Jonathan Frederickson <jonathan@terracrypt.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4401,6 +4402,38 @@ minimum.")
(home-page "https://git.zrythm.org/cgit/ztoolkit/")
(license license:agpl3+)))
+(define-public libinstpatch
+ (package
+ (name "libinstpatch")
+ (version "1.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swami/libinstpatch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0psx4hc5yksfd3k2xqsc7c8lbz2d4yybikyddyd9hlkhq979cmjb"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;there are no tests
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("libsndfile" ,libsndfile)))
+ (home-page "http://www.swamiproject.org/")
+ (synopsis "Instrument file software library")
+ (description
+ "libInstPatch is a library for processing digital sample based MIDI
+instrument \"patch\" files. The types of files libInstPatch supports are used
+for creating instrument sounds for wavetable synthesis. libInstPatch provides
+an object framework (based on GObject) to load patch files, which can then be
+edited, converted, compressed and saved.")
+ (license license:lgpl2.1)))
+
(define-public ztoolkit-rsvg
(package
(inherit ztoolkit)