summaryrefslogtreecommitdiff
path: root/gnu/packages/attr.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-06-11 23:52:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-06-11 23:52:15 +0200
commita032b4454b3fc67e11e9fc2d8c2345288065fa29 (patch)
treec208124b79dbd2224b68c52106aa72ff2ebfa7ab /gnu/packages/attr.scm
parentb5724230fed2d043206df20d12a45bb962b7ee77 (diff)
parent6321ce42ab4d9ab788d858cb19bde4aa7a0e3ecc (diff)
downloadguix-patches-a032b4454b3fc67e11e9fc2d8c2345288065fa29.tar
guix-patches-a032b4454b3fc67e11e9fc2d8c2345288065fa29.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/attr.scm')
-rw-r--r--gnu/packages/attr.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/attr.scm b/gnu/packages/attr.scm
index fe102d211c..ff0a07aa67 100644
--- a/gnu/packages/attr.scm
+++ b/gnu/packages/attr.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2012, 2013, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,13 +43,14 @@
(modify-phases %standard-phases
(add-after 'configure 'patch-makefile-SHELL
(lambda _
- (patch-makefile-SHELL "include/buildmacros")))
+ (patch-makefile-SHELL "include/buildmacros")
+ #t))
(replace 'install
(lambda _
- (zero? (system* "make"
- "install"
- "install-lib"
- "install-dev"))))
+ (invoke "make"
+ "install"
+ "install-lib"
+ "install-dev")))
(replace 'check
(lambda* (#:key target #:allow-other-keys)
;; Use the right shell.
@@ -57,11 +59,14 @@
(which "sh")))
;; When building natively, run the tests.
+ ;;
+ ;; Note that we use system* and unconditionally return #t here
+ ;; to ignore the test result, because the tests will fail when
+ ;; the build is performed on a file system without support for
+ ;; extended attributes, and we wish to allow Guix to be built
+ ;; on such systems.
(unless target
(system* "make" "tests" "-C" "test"))
-
- ;; XXX: Ignore the test result since this is
- ;; dependent on the underlying file system.
#t)))))
(inputs
;; Perl is needed to run tests; remove it from cross builds.