summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-31 15:06:36 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-31 15:06:36 +0200
commit2ac1978a9fe7632f1151da8a3510aadeeb7708ae (patch)
treeba0062b562d76a45d66bc98c2dfa6b6e6c922a19 /gnu/packages/android.scm
parent8948bc7e44c844b68f660d160dbc940fef085e0c (diff)
downloadguix-patches-2ac1978a9fe7632f1151da8a3510aadeeb7708ae.tar
guix-patches-2ac1978a9fe7632f1151da8a3510aadeeb7708ae.tar.gz
gnu: adb: Fix build.
* gnu/packages/android.scm (adb)[arguments]: Use gexp for 'make-flags".
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index f09d8e9522..630a626ba2 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Sergey Trofimov <sarg@sarg.org.ru>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,6 +31,7 @@
(define-module (gnu packages android)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system android-ndk)
#:use-module (guix build-system gnu)
@@ -360,10 +362,10 @@ various Android core host applications.")
(arguments
`(#:tests? #f ; Test failure: sysdeps_poll.fd_count
#:make-flags
- (list "CFLAGS=-Wno-error"
- "CXXFLAGS=-fpermissive -Wno-error -std=gnu++14 -D_Nonnull= -D_Nullable= -I ."
- (string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out") "/lib "
- "-Wl,-rpath=" (assoc-ref %build-inputs "openssl") "/lib -L ."))
+ ,#~(list "CFLAGS=-Wno-error"
+ "CXXFLAGS=-fpermissive -Wno-error -std=gnu++14 -D_Nonnull= -D_Nullable= -I ."
+ (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib "
+ "-Wl,-rpath=" #$openssl "/lib -L ."))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'enter-source