summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2024-02-26 15:53:40 +0100
committerAndreas Enge <andreas@enge.fr>2024-02-26 15:54:03 +0100
commit8842826609f6e7b2af17f7fccaad0bdf2d9833bf (patch)
tree63e1a81bd9088bdb4f83c78ba7f7251db2ce1a0f /gnu/packages/algebra.scm
parentbaf4cd20d11081fa64c62657699205ba9d051699 (diff)
downloadguix-patches-8842826609f6e7b2af17f7fccaad0bdf2d9833bf.tar
guix-patches-8842826609f6e7b2af17f7fccaad0bdf2d9833bf.tar.gz
gnu: Add paritwine.
* gnu/packages/algebra.scm (paritwine): New variable. Change-Id: If2a55dd4a42d4d27a67249bd11592635ade20351
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 9fb28970db..90507ebd90 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2022 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2022, 2023, 2024 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2015, 2017, 2018, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016-2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
@@ -296,6 +296,34 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
(license license:gpl2)
(home-page "https://pari.math.u-bordeaux.fr/")))
+(define-public paritwine
+ (package
+ (name "paritwine")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.multiprecision.org/downloads/" name
+ "-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "15m5jxmhx5zivk1k9wxpmzs8kqva3kvgxizdrkrmmp1qycn85n23"))))
+ (build-system gnu-build-system)
+ (propagated-inputs (list pari-gp
+ gmp
+ mpfr
+ mpc
+ cmh
+ flint)) ; referenced in src/paritwine.h
+ (synopsis "Glue library between PARI/GP and other mathematics libraries")
+ (description
+ "PariTwine is a glue library between the system for computer algebra
+and number theory PARI/GP and a number of other mathematics libraries,
+currently GMP, GNU MPFR, GNU MPC, FLINT and CMH.")
+ (license license:gpl2+)
+ (home-page "https://www.multiprecision.org/paritwine/index.html")))
+
(define-public cmh
(package
(name "cmh")