summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-22 03:08:10 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-28 21:30:28 +0200
commite57817c4728022b97bb02777dee324f35847986e (patch)
tree2d394418057d7d6212b672c016c40d8228bb4c33 /gnu/packages/algebra.scm
parent7b2a30d8b4037058f53344b5a6e2a4c0d212930d (diff)
downloadguix-patches-e57817c4728022b97bb02777dee324f35847986e.tar
guix-patches-e57817c4728022b97bb02777dee324f35847986e.tar.gz
gnu: Add ginac.
* gnu/packages/algebra.scm (ginac): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3c21a1b556..58873c7a60 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;;
;;; This file is part of GNU Guix.
@@ -986,6 +986,36 @@ Optional thin wrappers allow usage of the library from other languages.")
(license (list license:expat ;SymEngine
license:bsd-3)))) ;3rd party code
+(define-public ginac
+ (package
+ (name "ginac")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.ginac.de/ginac-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1az1ypfcny4jdz0mic1kywwa9nynr547cl5s7zpn2w0qdfymssgi"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list "--disable-static")))
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper))) ; Python is required
+ (inputs
+ `(("cln" ,cln)
+ ("readline" ,readline)))
+ (home-page "https://www.ginac.de/")
+ (synopsis "Library for symbolic computation")
+ (description "GiNaC is a C++ library for symbolic computation. Contrary
+to other CAS it does not try to provide extensive algebraic capabilities and a
+simple programming language but instead accepts a given language (C++) and
+extends it by a set of algebraic capabilities.")
+ (license license:gpl2+)))
+
(define-public eigen
(package
(name "eigen")