summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/algebra.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 97bc7c9824..f77db63999 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -343,7 +343,7 @@ precision.")
(define-public giac
(package
(name "giac")
- (version "1.7.0-31")
+ (version "1.7.0-37")
(source
(origin
(method url-fetch)
@@ -355,7 +355,7 @@ precision.")
"~parisse/debian/dists/stable/main/source/"
"giac_" version ".tar.gz"))
(sha256
- (base32 "19vjyijlm3hb758h6nk70k41zw9wrbg6vwfx4r4rgvrb1myy5kpl"))))
+ (base32 "1mzqf7r40ppmzixf4s6sjk76y0wpcf6xp7hklzrn2l1910ld61pz"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 ftw)
@@ -431,13 +431,13 @@ or text interfaces) or as a C++ library.")
(define-public flint
(package
(name "flint")
- (version "2.6.3")
+ (version "2.8.1")
(source
(origin
(method url-fetch)
(uri (string-append "http://flintlib.org/flint-" version ".tar.gz"))
(sha256
- (base32 "1qrf6hzbbmg7mhkhbb0bab8z2xpdnba5cj4kmmf72lzs0457a6nf"))))
+ (base32 "0zj2zgn3cbb08pxhfq38i62pgjfbb6938l70am7dnixqgixdmzgd"))))
(build-system gnu-build-system)
(inputs
`(("ntl" ,ntl)))
@@ -485,7 +485,7 @@ fast arithmetic.")
(define-public arb
(package
(name "arb")
- (version "2.18.1")
+ (version "2.21.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -494,7 +494,7 @@ fast arithmetic.")
(file-name (git-file-name name version))
(sha256
(base32
- "15fx3dcbzgwddw9p1nysmx0dbh058afv5m8cj5pdjkcmcl7kw7z9"))))
+ "0c7q8bbm2izh0j0342v0dkgg1lgd6f0fn3i9x9x80brjjhg65q7b"))))
(build-system gnu-build-system)
(propagated-inputs
`(("flint" ,flint))) ; flint.h is included by arf.h
@@ -609,7 +609,7 @@ matrices, and polynomials over the integers and over finite fields.")
(define-public singular
(package
(name "singular")
- (version "4.1.3p2")
+ (version "4.2.1")
(source
(origin
(method url-fetch)
@@ -618,12 +618,13 @@ matrices, and polynomials over the integers and over finite fields.")
"Singular/SOURCES/"
(string-join
(string-split
- (string-trim-right version #\p
- 0 (1- (string-length version)))
+ (let ((index (string-index version #\p)))
+ (if index (string-take version index)
+ version))
#\.) "-")
"/singular-" version ".tar.gz"))
(sha256 (base32
- "1524yrni7gh0hir5ckridq671q5s6avfjdsdyahj51kzdl3wcypf"))))
+ "13gy1gdng8zijwlr1fn5sixw53z0zf9czzlg0vh1dcc59zw6v998"))))
(build-system gnu-build-system)
(native-inputs
`(("doxygen" ,doxygen)