summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-04-05 03:10:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-04-05 03:31:58 +0200
commitf0bacad682734371fc5b5ed732625ae2c629973b (patch)
treefd9dda32e6c975cfaa04934915f05aec85e115f2 /gnu/packages/algebra.scm
parent5894b60491d76c3d8208d64c445684d5d8b1d756 (diff)
downloadguix-patches-f0bacad682734371fc5b5ed732625ae2c629973b.tar
guix-patches-f0bacad682734371fc5b5ed732625ae2c629973b.tar.gz
gnu: bc: Actually use readline.
* gnu/packages/algebra.scm (bc)[arguments]: Add ‘--with-readline’ to #:configure-flags.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index d7f3203d23..ab73a6e2e5 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -494,7 +495,9 @@ binary.")
;; PREFIX/share/{man,info}.
(string-append "--mandir=" out "/share/man")
(string-append "--infodir=" out "/share/info")))))
- %standard-phases)))
+ %standard-phases)
+ #:configure-flags
+ (list "--with-readline")))
(home-page "https://www.gnu.org/software/bc/")
(synopsis "Arbitrary precision numeric processing language")
(description