summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-04-05 01:14:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-04-05 03:31:58 +0200
commitdfee7daedb760f1b1d7506829ca31633f4173356 (patch)
treef1c964e711fef3be3810514c919db76908d6b68a /gnu/packages/algebra.scm
parentf0bacad682734371fc5b5ed732625ae2c629973b (diff)
downloadguix-patches-dfee7daedb760f1b1d7506829ca31633f4173356.tar
guix-patches-dfee7daedb760f1b1d7506829ca31633f4173356.tar.gz
gnu: bc: Update to 1.07.
* gnu/packages/algebra.scm (bc): Update to 1.07. [native-inputs]: Add ed and texinfo. [arguments]: Use default ‘configure’ phase.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm33
1 files changed, 11 insertions, 22 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index ab73a6e2e5..96720bd593 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages ed)
#:use-module (gnu packages flex)
#:use-module (gnu packages fltk)
#:use-module (gnu packages gl)
@@ -39,6 +40,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages shells)
#:use-module (gnu packages tex)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
@@ -468,35 +470,22 @@ binary.")
(define-public bc
(package
(name "bc")
- (version "1.06")
+ (version "1.07")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/bc/bc-" version ".tar.gz"))
(sha256
(base32
- "0cqf5jkwx6awgd2xc2a0mkpxilzcfmhncdcfg7c9439wgkqxkxjf"))))
+ "1b852b39y43zrbya7d8civ7vmdbfap5v1ivc70ypr3bj7b1izksm"))))
(build-system gnu-build-system)
- (inputs `(("readline" ,readline)))
- (native-inputs `(("flex" ,flex)))
+ (inputs
+ `(("readline" ,readline)))
+ (native-inputs
+ `(("ed" ,ed)
+ ("flex" ,flex)
+ ("texinfo" ,texinfo)))
(arguments
- '(#:phases
- (alist-replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This old `configure' script doesn't support
- ;; variables passed as arguments.
- (let ((out (assoc-ref outputs "out")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system*
- "./configure"
- (string-append "--prefix=" out)
- ;; By default, man and info pages are put in
- ;; PREFIX/{man,info}, but we want them in
- ;; PREFIX/share/{man,info}.
- (string-append "--mandir=" out "/share/man")
- (string-append "--infodir=" out "/share/info")))))
- %standard-phases)
- #:configure-flags
+ '(#:configure-flags
(list "--with-readline")))
(home-page "https://www.gnu.org/software/bc/")
(synopsis "Arbitrary precision numeric processing language")