summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-25 22:58:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:16 +0100
commit45591fd7fde1a400a416cb99939f6dd766445f94 (patch)
treeefba6315ddd67a84b9d6c89f7c10c4c7a22831d0 /gnu/packages/algebra.scm
parenta82f0b36177848eda340d880ae0802c3e26c4ea8 (diff)
downloadguix-patches-45591fd7fde1a400a416cb99939f6dd766445f94.tar
guix-patches-45591fd7fde1a400a416cb99939f6dd766445f94.tar.gz
gnu: Add threaded variants of fftw and fftwf for Ardour and mod-host.
* gnu/packages/algebra.scm (fftw-with-threads, fftwf-with-threads): New variables. * gnu/packages/audio.scm (ardour)[inputs]: Replace "fftw" and "fftwf" with "fftw-with-threads" and "fftwf-with-threads", respectively. * gnu/packages/music.scm (mod-host)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 76f385e340..4288913f78 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -576,6 +576,22 @@ cosine/ sine transforms or DCT/DST).")
(string-append (package-description fftw)
" Single-precision version."))))
+;; FIXME: These packages are used temporarily by packages like Ardour until
+;; "--enable-flags" is added to the fftw and fftwf packages.
+(define-public fftw-with-threads
+ (package (inherit fftw)
+ (arguments
+ (substitute-keyword-arguments (package-arguments fftw)
+ ((#:configure-flags flags)
+ `(cons "--enable-threads" ,flags))))))
+
+(define-public fftwf-with-threads
+ (package (inherit fftwf)
+ (arguments
+ (substitute-keyword-arguments (package-arguments fftwf)
+ ((#:configure-flags flags)
+ `(cons "--enable-threads" ,flags))))))
+
(define-public fftw-openmpi
(package (inherit fftw)
(name "fftw-openmpi")