summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2018-11-16 09:06:31 +0100
committerAndreas Enge <andreas@enge.fr>2018-11-16 09:06:31 +0100
commiteea7cd751988733159f86e10e82525fab014e060 (patch)
treec0961563411230e9b6d5457b15a1a7e0c6130c0d /gnu/packages/algebra.scm
parent44ff80fc0ed8ac74523ed350982f5cfbbd150772 (diff)
downloadguix-patches-eea7cd751988733159f86e10e82525fab014e060.tar
guix-patches-eea7cd751988733159f86e10e82525fab014e060.tar.gz
gnu: Add cmh.
* gnu/packages/algebra.scm (cmh): New variable.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index e54b8e3512..103594364e 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
@@ -210,6 +210,36 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
(license license:gpl2)
(home-page "https://pari.math.u-bordeaux.fr/")))
+(define-public cmh
+ (package
+ (name "cmh")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gforge.inria.fr/frs/download.php/33497/cmh-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1a28xr9bs0igms0ik99x0w8lnb0jyfcmvyi26pbyh9ggcdivd33p"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gmp" ,gmp)
+ ("mpfr" ,mpfr)
+ ("mpc" ,mpc)
+ ("mpfrcx" ,mpfrcx)
+ ("fplll" ,fplll)
+ ("pari-gp" ,pari-gp)))
+ (synopsis "Igusa class polynomial computations")
+ (description
+ "The CMH software computes Igusa (genus 2) class polynomials, which
+parameterize the CM points in the moduli space of 2-dimensional abelian
+varieties, i.e. Jacobians of hyperelliptic curves.
+It can also be used to compute theta constants at arbitrary
+precision.")
+ (license license:gpl3+)
+ (home-page "http://cmh.gforge.inria.fr/")))
+
(define-public giac-xcas
(package
(name "giac-xcas")