summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-07-26 09:30:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-07-26 09:30:39 +0200
commit35b3c7c8ebc709fcd4773257395ec5e42671e415 (patch)
treec9eb4bdc439319f9524efe56b07e162cecf71b0e /gnu/packages/algebra.scm
parenteb1a5dddda0fd34d480f99f1c63634b8eaa40d32 (diff)
downloadguix-patches-35b3c7c8ebc709fcd4773257395ec5e42671e415.tar
guix-patches-35b3c7c8ebc709fcd4773257395ec5e42671e415.tar.gz
gnu: giac: Update to 1.7.0-21.
* gnu/packages/algebra.scm (giac): Update to 1.7.0-21.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2b1d82b9ee..6450ac8914 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -343,7 +343,7 @@ precision.")
(define-public giac
(package
(name "giac")
- (version "1.7.0-17")
+ (version "1.7.0-21")
(source
(origin
(method url-fetch)
@@ -355,7 +355,7 @@ precision.")
"~parisse/debian/dists/stable/main/source/"
"giac_" version ".tar.gz"))
(sha256
- (base32 "0yh556wlgs9hfyp5j2xz4nlrd2dma63cicrc3dhahyl96y1aw6mr"))))
+ (base32 "1w8wyz559ljsjxf5xjkjvgkac1xpj71qzy6sycnbsqza4m0j28l5"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 ftw)
@@ -368,14 +368,12 @@ precision.")
(lambda _
(substitute* (cons "micropython-1.12/xcas/Makefile"
(find-files "doc" "^Makefile"))
- (("/bin/cp") (which "cp")))
- #t))
+ (("/bin/cp") (which "cp")))))
(add-after 'unpack 'disable-failing-test
;; FIXME: Test failing. Not sure why.
(lambda _
(substitute* "check/Makefile.in"
- (("chk_fhan11") ""))
- #t))
+ (("chk_fhan11") ""))))
(add-after 'install 'fix-doc
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -388,13 +386,11 @@ precision.")
;; Remove duplicate documentation in
;; "%out/share/doc/giac/", where Xcas does not expect
;; to find it.
- (delete-file-recursively (string-append out "/share/doc/giac"))
- #t)))
+ (delete-file-recursively (string-append out "/share/doc/giac")))))
(add-after 'install 'remove-unnecessary-executable
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (delete-file (string-append out "/bin/xcasnew"))
- #t))))))
+ (delete-file (string-append out "/bin/xcasnew"))))))))
(inputs
;; TODO: Add libnauty, unbundle "libmicropython.a".
`(("fltk" ,fltk)