summaryrefslogtreecommitdiff
path: root/gnu/packages/agda.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/agda.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/agda.scm')
-rw-r--r--gnu/packages/agda.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index de7454c4e8..606b0e48b5 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -49,28 +49,28 @@
"159hznnsxg7hlp80r1wqizyd7gwgnq0j13cm4d27cns0ganslb07"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-aeson" ,ghc-aeson)
- ("ghc-alex" ,ghc-alex)
- ("ghc-async" ,ghc-async)
- ("ghc-blaze-html" ,ghc-blaze-html)
- ("ghc-boxes" ,ghc-boxes)
- ("ghc-case-insensitive" ,ghc-case-insensitive)
- ("ghc-data-hash" ,ghc-data-hash)
- ("ghc-edit-distance" ,ghc-edit-distance)
- ("ghc-equivalence" ,ghc-equivalence)
- ("ghc-gitrev" ,ghc-gitrev)
- ("ghc-happy" ,ghc-happy)
- ("ghc-hashable" ,ghc-hashable)
- ("ghc-hashtables" ,ghc-hashtables)
- ("ghc-monad-control" ,ghc-monad-control)
- ("ghc-murmur-hash" ,ghc-murmur-hash)
- ("ghc-parallel" ,ghc-parallel)
- ("ghc-regex-tdfa" ,ghc-regex-tdfa)
- ("ghc-split" ,ghc-split)
- ("ghc-strict" ,ghc-strict)
- ("ghc-unordered-containers" ,ghc-unordered-containers)
- ("ghc-uri-encode" ,ghc-uri-encode)
- ("ghc-zlib" ,ghc-zlib)))
+ (list ghc-aeson
+ ghc-alex
+ ghc-async
+ ghc-blaze-html
+ ghc-boxes
+ ghc-case-insensitive
+ ghc-data-hash
+ ghc-edit-distance
+ ghc-equivalence
+ ghc-gitrev
+ ghc-happy
+ ghc-hashable
+ ghc-hashtables
+ ghc-monad-control
+ ghc-murmur-hash
+ ghc-parallel
+ ghc-regex-tdfa
+ ghc-split
+ ghc-strict
+ ghc-unordered-containers
+ ghc-uri-encode
+ ghc-zlib))
(arguments
`(#:modules ((guix build haskell-build-system)
(guix build utils)
@@ -139,7 +139,7 @@ Agda. It also aids the input of Unicode characters.")))
"0dlis6v6nzbscf713cmwlx8h9n2gxghci8y21qak3hp18gkxdp0g"))))
(build-system gnu-build-system)
(inputs
- `(("agda" ,agda)))
+ (list agda))
(arguments
`(#:parallel-build? #f
#:phases