summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-18 14:21:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 14:21:10 +0300
commit1076f32111e512ed437f135c9eb6ce2daaafd623 (patch)
tree5e9c528dc4c07ade05ab6442be06e400e7336812 /gnu/packages/admin.scm
parent202c97c4ce2e948266b8b6ee4d80631adbfba92b (diff)
downloadguix-patches-1076f32111e512ed437f135c9eb6ce2daaafd623.tar
guix-patches-1076f32111e512ed437f135c9eb6ce2daaafd623.tar.gz
gnu: isc-dhcp: Fix cross-compilation to powerpc-linux.
* gnu/packages/admin.scm (isc-dhcp)[arguments]: Adjust the custom 'fix-bind-cross-compilation phase to force linking with '-latomic' when building for powerpc-linux.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 05e3936b0a..4f55c926fe 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1479,14 +1479,18 @@ connection alive.")
(("^RELEASEVER=.*")
(format #f "RELEASEVER=~a\n" ,bind-release-version)))))
,@(if (%current-target-system)
- '((add-before 'configure 'fix-bind-cross-compilation
+ `((add-before 'configure 'fix-bind-cross-compilation
(lambda _
(substitute* "configure"
(("--host=\\$host")
"--host=$host_alias"))
;; BIND needs a native compiler because the DHCP
;; build system uses the built 'gen' executable.
- (setenv "BUILD_CC" "gcc"))))
+ (setenv "BUILD_CC" "gcc")
+ ;; powerpc-linux needs to be told to use -latomic.
+ ,@(if (target-ppc32?)
+ `((setenv "LIBS" "-latomic"))
+ '()))))
'())
(add-before 'configure 'update-config-scripts
(lambda* (#:key native-inputs inputs #:allow-other-keys)