summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-28 13:46:47 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-28 13:52:45 -0400
commite91a5258584026935daacd4543d5b3aa76e6c8f6 (patch)
treecc3e875fd54fb36799f53e45083b525a3a7e5b77 /gnu/packages/admin.scm
parent7d136be00f5db191bf8450e977bb6fcb386e5dd8 (diff)
downloadguix-patches-e91a5258584026935daacd4543d5b3aa76e6c8f6.tar
guix-patches-e91a5258584026935daacd4543d5b3aa76e6c8f6.tar.gz
gnu: ansible: Use GUIX_PYTHONPATH in the search path specification.
* gnu/packages/admin.scm (ansible)[native-search-paths]: Use GUIX_PYTHONPATH.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8331c42f8b..2c47fb318d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2706,15 +2706,15 @@ provides the following commands:
(build-system python-build-system)
(propagated-inputs
(list ansible-core))
- ;; The Ansible collections are found by ansible-core via PYTHONPATH; the
- ;; following search path ensures that they are found even when Python is
- ;; not present in the profile.
+ ;; The Ansible collections are found by ansible-core via the Python search
+ ;; path; the following search path ensures that they are found even when
+ ;; Python is not present in the profile.
(native-search-paths
;; XXX: Attempting to use (package-native-search-paths python)
;; here would cause an error about python being an unbound
;; variable in the tests/cpan.scm test.
(list (search-path-specification
- (variable "PYTHONPATH")
+ (variable "GUIX_PYTHONPATH")
(files (list "lib/python3.9/site-packages")))))
(home-page "https://www.ansible.com/")
(synopsis "Radically simple IT automation")