summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-05 19:15:25 -0400
committerLeo Famulari <leo@famulari.name>2016-10-05 19:15:25 -0400
commitb19c7989b770f47011cd531a13c89002374dc3e0 (patch)
treeca0dccd3a677d4ac5237de87c9f78c31dbdaf148 /gnu/packages/admin.scm
parent6524c1cfcf6088c5574e6ff21f540dfb22f944bf (diff)
parent145947608905d36f31227e87bebd7ed3a922e910 (diff)
downloadguix-patches-b19c7989b770f47011cd531a13c89002374dc3e0.tar
guix-patches-b19c7989b770f47011cd531a13c89002374dc3e0.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm100
1 files changed, 88 insertions, 12 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6d298843c3..f608259382 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -210,16 +210,27 @@ application (for console or X terminals) and requires ncurses.")
(define-public pies
(package
(name "pies")
- (version "1.2")
+ (version "1.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/pies/pies-"
- version ".tar.bz2"))
- (sha256
- (base32
- "18w0dbg77i56cx1bwa789w0qi3l4xkkbascxcv2b6gbm0zmjg1g6"))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/pies/pies-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "12r7rjjyibjdj08dvwbp0iflfpzl4s0zhn6cr6zj3hwf9gbzgl1g"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'build 'patch-/bin/sh
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Use the right shell when executing user-provided
+ ;; shell commands.
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "src/progman.c"
+ (("\"/bin/sh\"")
+ (string-append "\"" bash "/bin/sh\"")))
+ #t))))))
(home-page "http://www.gnu.org/software/pies/")
(synopsis "Program invocation and execution supervisor")
(description
@@ -1180,14 +1191,14 @@ environment variable is set and output is to tty.")
(define-public direvent
(package
(name "direvent")
- (version "5.0")
+ (version "5.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/direvent/direvent-"
version ".tar.gz"))
(sha256
(base32
- "1i14131y6m8wvirz6piw4zxz2q1kbpl0lniv5kl55rx4k372dg8z"))
+ "1nwvjmx7kb14ni34c0b8x9a3791pc20gvhj7xaj66d8q4h6n0qf4"))
(modules '((guix build utils)))
(snippet '(substitute* "tests/testsuite"
(("#![[:blank:]]?/bin/sh")
@@ -1197,11 +1208,19 @@ environment variable is set and output is to tty.")
'(#:phases (alist-cons-before
'build 'patch-/bin/sh
(lambda* (#:key inputs #:allow-other-keys)
- ;; Use the right shell when executing the watcher.
+ ;; Use the right shell when executing the watcher and
+ ;; user-provided shell commands.
(let ((bash (assoc-ref inputs "bash")))
- (substitute* "src/direvent.c"
+ (substitute* '("src/direvent.c" "src/progman.c")
(("\"/bin/sh\"")
- (string-append "\"" bash "/bin/sh\"")))))
+ (string-append "\"" bash "/bin/sh\"")))
+
+ ;; Adjust the 'shell.at' test accordingly.
+ (substitute* "tests/testsuite"
+ (("SHELL=/bin/sh")
+ (string-append "SHELL=" bash "/bin/sh")))
+
+ #t))
%standard-phases)))
(home-page "http://www.gnu.org/software/direvent/")
(synopsis "Daemon to monitor directories for events such as file removal")
@@ -1846,3 +1865,60 @@ Kerberos and Heimdal and FAST is supported with recent MIT Kerberos.")
(license license:gpl1+)))
;;http://archives.eyrie.org/software/kerberos/pam-krb5-4.7.tar.xz
+
+(define-public sunxi-tools
+ (package
+ (name "sunxi-tools")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/linux-sunxi/"
+ "sunxi-tools/archive/v" version ".tar.gz"))
+ (sha256
+ (base32 "1iazm28gws1i8sls3gxwc5p108n56ags287zmh1rpvkn2k1az81a"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Remove binaries contained in the tarball which are only for the
+ ;; target and can be regenerated anyway.
+ '(delete-file-recursively "bin"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libusb" ,libusb)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests exist
+ #:make-flags (list (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ "TARGET_TOOLS=sunxi-pio sunxi-meminfo"
+ "CROSS_COMPILE=")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-Makefile
+ (lambda _
+ (substitute* "Makefile"
+ ;; Upstream adds Makefile and config.h as dependencies
+ ;; of all their tools which means $^ would pass them to gcc.
+ ;; gcc won't know what to do with a Makefile.
+ (("-o [$][@] [$]\\^") "-o $@ meminfo.c"))
+ #t))
+ (delete 'configure))))
+ (home-page "https://github.com/linux-sunxi/sunxi-tools")
+ (synopsis "Hardware management tools for Allwinner computers")
+ (description "This package contains tools for Allwinner devices:
+@enumerate
+@item @command{sunxi-fexc}, @command{bin2fex}, @command{fex2bin}: Compile
+a textual description of a board (.fex) to a binary representation (.bin).
+@item @command{sunxi-fel}: Puts an Allwinner device into FEL mode which
+makes it register as a special USB device (rather than USB host).
+You can then connect it to another computer and flash it from there.
+@item @command{sunxi-nand-part}: Partitions NAND flash.
+@item @command{sunxi-bootinfo}: Reads out boot0 and boot1 (Allwinner
+bootloader) parameters.
+@item @command{sunxi-pio}: Sets GPIO parameters and oscillates a GPIO
+in order to be able to find it.
+@item @command{sunxi-meminfo}: Prints memory bus settings.
+@end enumerate")
+ (license license:gpl2+)))