summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-21 21:49:36 -0400
committerMark H Weaver <mhw@netris.org>2014-08-21 21:49:36 -0400
commitfa5731baabdb4a9240aad2154847f352aed02d6e (patch)
tree87366393bf36a042969ac1ed36c2fc6e77a2c21e /gnu/packages/admin.scm
parentc3114b756760ddb73054a4bc3d5eff0bfe47c4de (diff)
downloadguix-patches-fa5731baabdb4a9240aad2154847f352aed02d6e.tar
guix-patches-fa5731baabdb4a9240aad2154847f352aed02d6e.tar.gz
Revert "gnu: Add 'file' as a native-input on MIPS for some packages."
This reverts commit c3114b756760ddb73054a4bc3d5eff0bfe47c4de.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 83b01808cd..c2599746d8 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -29,7 +29,6 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages base)
- #:use-module (gnu packages file)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages readline)
#:use-module (gnu packages linux)
@@ -649,7 +648,18 @@ system administrator.")
"")
(("^install: (.*)install-sudoers(.*)" _ before after)
;; Don't try to create /etc/sudoers.
- (string-append "install: " before after "\n"))))
+ (string-append "install: " before after "\n")))
+
+ ;; XXX FIXME sudo 1.8.10p3 was bootstrapped with a
+ ;; prerelease libtool, which fails on MIPS in the absence
+ ;; of /usr/bin/file. As a temporary workaround, we patch
+ ;; the configure script to hardcode use of the little
+ ;; endian N32 ABI on MIPS.
+ ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+ (%current-system)))
+ '((substitute* "configure"
+ (("\\$emul") "elf32ltsmipn32")))
+ '()))
%standard-phases)
;; XXX: The 'testsudoers' test series expects user 'root' to exist, but
@@ -659,12 +669,6 @@ system administrator.")
`(("groff" ,groff)
("linux-pam" ,linux-pam)
("coreutils" ,coreutils)))
- (native-inputs
- `(;; 'file' is needed by the pre-release libtool on MIPS.
- ,@(if (equal? "mips64el-linux" (or (%current-target-system)
- (%current-system)))
- `(("file" ,file))
- '())))
(home-page "http://www.sudo.ws/")
(synopsis "Run commands as root")
(description