summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 02:52:53 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:26:44 +0200
commit24d459cecafb1dec84d7bf6587f0d468d759c3a5 (patch)
tree39dcd84fbd5bb0568c0834b1e121bfd7b8c3a12a /gnu/packages/admin.scm
parent7710b8f8adf96bd85c243bd8d61cd7485209d6b0 (diff)
downloadguix-patches-24d459cecafb1dec84d7bf6587f0d468d759c3a5.tar
guix-patches-24d459cecafb1dec84d7bf6587f0d468d759c3a5.tar.gz
gnu: autojump: Don't use unstable tarball.
* gnu/packages/admin.scm (autojump)[source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Add ‘make-git-checkout-writable’ phase.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1b1b567a6f..463a0492ac 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1739,15 +1739,15 @@ limits.")
(version "22.5.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/wting/autojump/archive/"
- "release-v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wting/autojump.git")
+ (commit (string-append "release-v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "17z9j9936x0nizwrzf664bngh60x5qbvrrf1s5qdzd0f2gdanpvn"))))
+ (base32 "1l1278g3k1qfrz41pkpjdhsabassb9si2d1bfbcmvbv5h3wmlqk9"))))
(build-system gnu-build-system)
- (native-inputs ;for tests
+ (native-inputs ; for tests
`(("python-mock" ,python-mock)
("python-pytest" ,python-pytest)))
(inputs
@@ -1755,6 +1755,11 @@ limits.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ ;; ‘install.py’ modifies files before installing them.
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
(delete 'configure)
(delete 'build)
(replace 'check