summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-26 02:04:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-26 09:48:37 +0200
commit332a2765031a39fd02a23a16492f68ec3a597b1b (patch)
treef109bbcc1b609592a93608c21493930916d8db14 /gnu/packages/admin.scm
parent3d909a0acff72c7e8df8c2829af4ddfab310bdc2 (diff)
downloadguix-patches-332a2765031a39fd02a23a16492f68ec3a597b1b.tar
guix-patches-332a2765031a39fd02a23a16492f68ec3a597b1b.tar.gz
gnu: clusterssh: Run.
* gnu/packages/admin.scm (clusterssh)[arguments]: Add ’augment-library-path’ phase so libraries are found. [propagated-inputs]: Make all of these… [inputs]: …regular.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm33
1 files changed, 29 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 42dc4396eb..c3b1e04901 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -931,7 +931,33 @@ by bandwidth they use.")
;; Update the manifest so t/manifest.t happily passes.
(substitute* "MANIFEST"
(("t/perltidy.t\n") ""))
- #t)))))
+ #t))
+ (add-after 'install 'augment-library-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (with-directory-excursion bin
+ (for-each
+ (lambda (program)
+ (wrap-program program
+ `("PERL5LIB" ":" prefix
+ ,(map (lambda (file-name)
+ (string-append file-name
+ "/lib/perl5/site_perl"))
+ (cons out
+ (map (lambda (input)
+ (assoc-ref inputs input))
+ ;; These may be propagated and hence
+ ;; not explicitly listed as inputs.
+ (list "perl-class-data-inheritable"
+ "perl-devel-stacktrace"
+ "perl-exception-class"
+ "perl-tk"
+ "perl-try-tiny"
+ "perl-x11-protocol"
+ "perl-x11-protocol-other")))))))
+ (find-files "." ".*")))
+ #t))))))
(native-inputs
`(("perl-cpan-changes" ,perl-cpan-changes)
("perl-file-slurp" ,perl-file-slurp)
@@ -946,14 +972,13 @@ by bandwidth they use.")
("perl-test-trap" ,perl-test-trap)
("perltidy" ,perltidy)))
(inputs
- `(("xterm" ,xterm)))
- (propagated-inputs
`(("perl-exception-class" ,perl-exception-class)
("perl-sort-naturally" ,perl-sort-naturally)
("perl-tk" ,perl-tk)
("perl-try-tiny" ,perl-try-tiny)
("perl-x11-protocol" ,perl-x11-protocol)
- ("perl-x11-protocol-other" ,perl-x11-protocol-other)))
+ ("perl-x11-protocol-other" ,perl-x11-protocol-other)
+ ("xterm" ,xterm)))
;; The clusterssh.sourceforge.net address requires login to view
(home-page "https://sourceforge.net/projects/clusterssh/")
(synopsis "Secure concurrent multi-server terminal control")