summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-29 19:07:16 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-30 01:08:54 +0100
commit26787a70346fad8943a089fcc12547075595a509 (patch)
tree875b25005535cf9d64992854f279574a2702355b /gnu/packages/admin.scm
parent3848dafeb15a4746d826ad1f2940f9b769ec33f8 (diff)
downloadguix-patches-26787a70346fad8943a089fcc12547075595a509.tar
guix-patches-26787a70346fad8943a089fcc12547075595a509.tar.gz
gnu: thefuck: Update to 3.31.
* gnu/packages/admin.scm (thefuck): Update to 3.31. [arguments]: Don't call buggy settings.init() during test suite.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8dc5cacdb2..e640149a51 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3158,7 +3158,7 @@ throughput (in the same interval).")
(define-public thefuck
(package
(name "thefuck")
- (version "3.30")
+ (version "3.31")
(source
(origin
(method git-fetch)
@@ -3167,7 +3167,7 @@ throughput (in the same interval).")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0fnf78956pwhb9cgv1jmgypnkma5xzflkivfrkfiadbgin848yfg"))
+ (base32 "05h60gxky57nalc2hdkpg8wqyg16432x9gcb9wnwblplk98998kq"))
(patches (search-patches "thefuck-test-environ.patch"))))
(build-system python-build-system)
(arguments
@@ -3180,8 +3180,10 @@ throughput (in the same interval).")
(add-installed-pythonpath inputs outputs)
;; Some tests need write access to $HOME.
(setenv "HOME" "/tmp")
- (invoke "py.test" "-v")
- #t)))))
+ ;; Even with that, this function tries to mkdir /.config.
+ (substitute* "tests/test_utils.py"
+ (("settings\\.init\\(\\)") ""))
+ (invoke "py.test" "-v"))))))
(propagated-inputs
`(("python-colorama" ,python-colorama)
("python-decorator" ,python-decorator)