summaryrefslogtreecommitdiff
path: root/gnu/local.mk
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-14 21:53:25 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-14 22:09:38 +0200
commit92d00ca4661e186022732a47956a2bc0ef16be96 (patch)
tree048f65570b56a062cfe1e183d75c595c80cb7816 /gnu/local.mk
parent1ba0b1e6ec41afd94a3c5f907b1122204dcb5d9d (diff)
downloadguix-patches-92d00ca4661e186022732a47956a2bc0ef16be96.tar
guix-patches-92d00ca4661e186022732a47956a2bc0ef16be96.tar.gz
build: Remove 'gnu/packages/bootstrap' and its binaries.
* gnu/local.mk (bootstrapdir, bootstrap_i686_linuxdir) (bootstrap_armhf_linuxdir, bootstrap_aarch64_linuxdir) (bootstrap_mips64el_linuxdir, dist_bootstrap_i686_linux_DATA) (dist_bootstrap_armhf_linux_DATA, dist_bootstrap_aarch64_linux_DATA) (dist_bootstrap_mips64el_linux_DATA): Remove. (set-bootstrap-executable-permissions): Remove target. * Makefile.am (install-data-hook): Remove dependency on 'set-bootstrap-executable-permissions'. * gnu/packages/bootstrap: Remove directory. * tests/search-paths.scm ("evaluate-search-paths, separator is #f"): Adjust to match .../aux-files/linux-libre.
Diffstat (limited to 'gnu/local.mk')
-rw-r--r--gnu/local.mk35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b92f82e7cb..0ba0d1f194 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1385,38 +1385,3 @@ dist_patch_DATA = \
MISC_DISTRO_FILES = \
%D%/packages/ld-wrapper.in
-
-bootstrapdir = $(guilemoduledir)/%D%/packages/bootstrap
-bootstrap_i686_linuxdir = $(bootstrapdir)/i686-linux
-bootstrap_armhf_linuxdir = $(bootstrapdir)/armhf-linux
-bootstrap_aarch64_linuxdir = $(bootstrapdir)/aarch64-linux
-bootstrap_mips64el_linuxdir = $(bootstrapdir)/mips64el-linux
-
-dist_bootstrap_i686_linux_DATA = \
- %D%/packages/bootstrap/i686-linux/bash \
- %D%/packages/bootstrap/i686-linux/mkdir \
- %D%/packages/bootstrap/i686-linux/tar \
- %D%/packages/bootstrap/i686-linux/xz
-
-dist_bootstrap_armhf_linux_DATA = \
- %D%/packages/bootstrap/armhf-linux/bash \
- %D%/packages/bootstrap/armhf-linux/mkdir \
- %D%/packages/bootstrap/armhf-linux/tar \
- %D%/packages/bootstrap/armhf-linux/xz
-
-dist_bootstrap_aarch64_linux_DATA = \
- %D%/packages/bootstrap/aarch64-linux/bash \
- %D%/packages/bootstrap/aarch64-linux/mkdir \
- %D%/packages/bootstrap/aarch64-linux/tar \
- %D%/packages/bootstrap/aarch64-linux/xz
-
-dist_bootstrap_mips64el_linux_DATA = \
- %D%/packages/bootstrap/mips64el-linux/bash \
- %D%/packages/bootstrap/mips64el-linux/mkdir \
- %D%/packages/bootstrap/mips64el-linux/tar \
- %D%/packages/bootstrap/mips64el-linux/xz
-
-# Those files must remain executable, so they remain executable once
-# imported into the store.
-set-bootstrap-executable-permissions:
- chmod +x $(DESTDIR)$(bootstrapdir)/*/{bash,mkdir,tar,xz}