summaryrefslogtreecommitdiff
path: root/gnu/installer.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-05-13 23:30:51 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-13 23:46:08 +0200
commit76269f6bc4200ef79aa80a8a6160ae269c2a36c9 (patch)
treeadea56c977be7aec00a919440234932a3ad34110 /gnu/installer.scm
parent1be065c4784805e7a7b4c3f08970d8e4043b0a60 (diff)
downloadguix-patches-76269f6bc4200ef79aa80a8a6160ae269c2a36c9.tar
guix-patches-76269f6bc4200ef79aa80a8a6160ae269c2a36c9.tar.gz
installer: Use 'glibc-supported-locales'.
The list of locales supported by glibc is now built from source. * gnu/installer/locale.scm (locale-string->locale): Add optional 'codeset' parameter and honor it. (supported-locales->locales): Rewrite to 'read' from SUPPORTED-LOCALES. * gnu/installer.scm (compute-locale-step): Pass the result of 'glibc-supported-locales' instead of the "aux-files/SUPPORTED" file. * gnu/installer/aux-files/SUPPORTED: Remove. * gnu/local.mk (dist_installer_DATA): Remove it.
Diffstat (limited to 'gnu/installer.scm')
-rw-r--r--gnu/installer.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index fe2841397e..3dd76707bf 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages package-management)
#:use-module (gnu packages xorg)
+ #:use-module (gnu system locale)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1)
#:export (installer-program))
@@ -118,7 +119,7 @@ been performed at build time."
(string-append #$file "/" #$name ".go")))
(let* ((supported-locales #~(supported-locales->locales
- #$(local-file "installer/aux-files/SUPPORTED")))
+ #+(glibc-supported-locales)))
(iso-codes #~(string-append #$iso-codes "/share/iso-codes/json/"))
(iso639-3 #~(string-append #$iso-codes "iso_639-3.json"))
(iso639-5 #~(string-append #$iso-codes "iso_639-5.json"))