summaryrefslogtreecommitdiff
path: root/gnu/installer.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 12:51:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 13:11:40 -0400
commit5e2140511c1ad9ccd731438b74d61b62111da1e6 (patch)
treea4ff748ad26e121b88469b5d921001ef1382be8f /gnu/installer.scm
parent9e3a5ee417ea7fe9721be8804ff047e80c4f22ed (diff)
parent353bdae32f72b720c7ddd706576ccc40e2b43f95 (diff)
downloadguix-patches-5e2140511c1ad9ccd731438b74d61b62111da1e6.tar
guix-patches-5e2140511c1ad9ccd731438b74d61b62111da1e6.tar.gz
Merge branch 'staging'
Conflicts: gnu/packages/admin.scm gnu/packages/commencement.scm gnu/packages/gdb.scm gnu/packages/llvm.scm gnu/packages/package-management.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/installer.scm')
-rw-r--r--gnu/installer.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index 5c3192d7a6..f401b242f8 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -71,7 +71,7 @@
(_ #f)))
(define* (build-compiled-file name locale-builder)
- "Return a file-like object that evalutes the gexp LOCALE-BUILDER and store
+ "Return a file-like object that evaluates the gexp LOCALE-BUILDER and store
its result in the scheme file NAME. The derivation will also build a compiled
version of this file."
(define set-utf8-locale
@@ -308,7 +308,8 @@ selected keymap."
;; translated.
#~(begin
(bindtextdomain "guix" (string-append #$guix "/share/locale"))
- (textdomain "guix")))
+ (textdomain "guix")
+ (setlocale LC_ALL "")))
(define set-installer-path
;; Add the specified binary to PATH for later use by the installer.