summaryrefslogtreecommitdiff
path: root/gnu/home-services.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2021-10-05 02:09:41 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-10-08 15:36:18 +0300
commitba8ddb348045f81f061a1c7f51c0f7c2b0024e71 (patch)
tree58feeca8579cccff3451a37ff0ef634e16f5b9c4 /gnu/home-services.scm
parent2e74616446ba6cc554547436e848637e7f61cb32 (diff)
downloadguix-patches-ba8ddb348045f81f061a1c7f51c0f7c2b0024e71.tar
guix-patches-ba8ddb348045f81f061a1c7f51c0f7c2b0024e71.tar.gz
gnu: Move (gnu home-services) to (gnu home services).
* gnu/home-services/configuration.scm: Move the content ... * gnu/home/services/configuration.scm: ... here. * doc/guix.texi: Replace (gnu home-services mcron) with (gnu home services mcron). Replace (gnu home-services) with (gnu home services). * gnu/home.scm: Replace (gnu home-services fontutils) with (gnu services fontutils). Replace (gnu home-services shells) with (gnu home services shells). Replace (gnu home-services symlink-manager) with (gnu home services symlink-manager). Replace (gnu home-services xdg) with (gnu home services xdg). * gnu/home-services/fontutils.scm: Rename to gnu/services/fontutils.scm. * gnu/home-services/mcron.scm: Move to gnu/home/services/mcron.scm. Replace (gnu home-services shepherd) with (gnu home services shepherd). * gnu/home-services.scm (%service-type-path): Search home services in "gnu/services". * gnu/home-services/shells.scm: Replace (gnu home-services configuration) with (gnu home services configuration). Rename to gnu/home/services/shells.scm. Replace (gnu home-services utils) with (gnu home services utils). * gnu/home-services/shepherd.scm: Move to gnu/home/services/shepherd.scm. * gnu/home-services/symlink-manager.scm: Rename to gnu/home/services/symlink-manager.scm. * gnu/home-services/utils.scm: Rename to gnu/home/services/utils.scm. * gnu/home-services/xdg.scm: Rename to gnu/home/services/xdg.scm. * guix/scripts/home/import.scm: Replace (gnu home-services bash) with (gnu home services bash). * gnu/home-services.scm: Update documentation string. * doc/he-config-bare-bones.scm: Apply new (gnu home-services ...) modules location. * gnu/local.mk (GNU_SYSTEM_MODULES): Same.
Diffstat (limited to 'gnu/home-services.scm')
-rw-r--r--gnu/home-services.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/home-services.scm b/gnu/home-services.scm
index 9f1e986616..a244a15511 100644
--- a/gnu/home-services.scm
+++ b/gnu/home-services.scm
@@ -512,10 +512,10 @@ environment, and its configuration file, when available.")))
(define %service-type-path
;; Search path for service types.
- (make-parameter `((,%guix-home-root-directory . "gnu/home-services"))))
+ (make-parameter `((,%guix-home-root-directory . "gnu/home/services"))))
(define (all-home-service-modules)
- "Return the default set of home-service modules."
+ "Return the default set of `home service' modules."
(cons (resolve-interface '(gnu home-services))
(all-modules (%service-type-path)
#:warn warn-about-load-error)))