summaryrefslogtreecommitdiff
path: root/emacs.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-04-21 18:07:52 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-04-21 18:47:50 +0200
commit03d0e2d2b9f9cc3be8e871842c11df9453e903bd (patch)
treea7cf97b70bf769217609beff73ec0c073d3f57f8 /emacs.am
parentdc9bdb1e2730589ff7c2ec5f1e601f4262eac9d6 (diff)
downloadguix-patches-03d0e2d2b9f9cc3be8e871842c11df9453e903bd.tar
guix-patches-03d0e2d2b9f9cc3be8e871842c11df9453e903bd.tar.gz
build: Move 'Makefile' fragments to subdirectories.
This follows a convention used by some other GNU packages like Autoconf, Bison, Coreutils, and Gnulib. * doc.am: Rename to ... * doc/local.mk: ... this. * emacs.am: Rename to ... * emacs/local.mk: ... this. * gnu-system.am: Rename to ... * gnu/local.mk: ... this. * daemon.am: Rename to ... * nix/local.mk: ... this. * Makefile.am: Adapt to them. * doc/guix.texi (Porting to a New Platform): Adapt documentation. * guix/config.scm.in (%state-directory, %config-directory): Adapt comments. * emacs/guix-config.el.in (guix-config-state-directory): Likewise.
Diffstat (limited to 'emacs.am')
-rw-r--r--emacs.am76
1 files changed, 0 insertions, 76 deletions
diff --git a/emacs.am b/emacs.am
deleted file mode 100644
index 62e33e4fd2..0000000000
--- a/emacs.am
+++ /dev/null
@@ -1,76 +0,0 @@
-# GNU Guix --- Functional package management for GNU
-# Copyright © 2014, 2015, 2016 Alex Kost <alezost@gmail.com>
-# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-#
-# This file is part of GNU Guix.
-#
-# GNU Guix is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or (at
-# your option) any later version.
-#
-# GNU Guix is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-AUTOLOADS = emacs/guix-autoloads.el
-
-ELFILES = \
- emacs/guix-backend.el \
- emacs/guix-base.el \
- emacs/guix-build-log.el \
- emacs/guix-buffer.el \
- emacs/guix-command.el \
- emacs/guix-devel.el \
- emacs/guix-emacs.el \
- emacs/guix-entry.el \
- emacs/guix-external.el \
- emacs/guix-geiser.el \
- emacs/guix-guile.el \
- emacs/guix-help-vars.el \
- emacs/guix-history.el \
- emacs/guix-hydra.el \
- emacs/guix-hydra-build.el \
- emacs/guix-hydra-jobset.el \
- emacs/guix-info.el \
- emacs/guix-init.el \
- emacs/guix-license.el \
- emacs/guix-list.el \
- emacs/guix-location.el \
- emacs/guix-messages.el \
- emacs/guix-pcomplete.el \
- emacs/guix-popup.el \
- emacs/guix-prettify.el \
- emacs/guix-profiles.el \
- emacs/guix-read.el \
- emacs/guix-ui.el \
- emacs/guix-ui-license.el \
- emacs/guix-ui-location.el \
- emacs/guix-ui-package.el \
- emacs/guix-ui-generation.el \
- emacs/guix-ui-system-generation.el \
- emacs/guix-utils.el
-
-if HAVE_EMACS
-
-dist_lisp_DATA = $(ELFILES)
-
-nodist_lisp_DATA = \
- emacs/guix-config.el \
- $(AUTOLOADS)
-
-$(AUTOLOADS): $(ELFILES)
- $(AM_V_EMACS)$(EMACS) --batch --eval \
- "(let ((backup-inhibited t) \
- (generated-autoload-file \
- (expand-file-name \"$(AUTOLOADS)\" \"$(builddir)\"))) \
- (update-directory-autoloads \
- (expand-file-name \"emacs\" \"$(srcdir)\")))"
-
-CLEANFILES += $(AUTOLOADS)
-
-endif HAVE_EMACS