summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:33:09 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:37:26 +0000
commite486b2b674badc80627b11077b7df2ac1cab92d8 (patch)
tree5909547a69c4b185b878c8f0fe8152f1c01fef04 /doc
parent0df1eb029efe5ebe3f02e36fa650cae4aaba89ec (diff)
parent88badc074a5dbebf80115918cf6c0009075154d2 (diff)
downloadguix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar
guix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'doc')
-rw-r--r--doc/contributing.texi2
-rw-r--r--doc/guix.texi18
-rw-r--r--doc/local.mk29
3 files changed, 17 insertions, 32 deletions
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 21caa9c08f..76ab913b0d 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -1223,7 +1223,7 @@ When a bug is resolved, please close the thread by sending an email to
If you have not done so already, you may wish to set a name and email
that will be associated with your commits (@pxref{telling git your name,
, Telling Git your name, git, Git User Manual}). If you wish to use a
-different name or email just for commits in this respository, you can
+different name or email just for commits in this repository, you can
use @command{git config --local}, or edit @file{.git/config} in the
repository instead of @file{~/.gitconfig}.
diff --git a/doc/guix.texi b/doc/guix.texi
index ab7082c83c..67a05a10ff 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -35925,7 +35925,7 @@ Available @code{home-shell-profile-configuration} fields are:
@item @code{profile} (default: @code{()}) (type: text-config)
@code{home-shell-profile} is instantiated automatically by
@code{home-environment}, DO NOT create this service manually, it can
-only be extended. @code{profile} is a list of strings or gexps, which
+only be extended. @code{profile} is a list of file-like objects, which
will go to @file{~/.profile}. By default @file{~/.profile} contains the
initialization code, which have to be evaluated by login shell to make
home-environment's profile avaliable to the user, but other commands can
@@ -35954,19 +35954,19 @@ Add sane defaults like reading @file{/etc/bashrc}, coloring output for
Association list of environment variables to set for the Bash session.
@item @code{bash-profile} (default: @code{()}) (type: text-config)
-List of strings or gexps, which will be added to @file{.bash_profile}.
+List of file-like objects, which will be added to @file{.bash_profile}.
Used for executing user's commands at start of login shell (In most
cases the shell started on tty just after login). @file{.bash_login}
won't be ever read, because @file{.bash_profile} always present.
@item @code{bashrc} (default: @code{()}) (type: text-config)
-List of strings or gexps, which will be added to @file{.bashrc}. Used
+List of file-like objects, which will be added to @file{.bashrc}. Used
for executing user's commands at start of interactive shell (The shell
for interactive usage started by typing @code{bash} or by terminal app
or any other program).
@item @code{bash-logout} (default: @code{()}) (type: text-config)
-List of strings or gexps, which will be added to @file{.bash_logout}.
+List of file-like objects, which will be added to @file{.bash_logout}.
Used for executing user's commands at the exit of login shell. It won't
be read in some cases (if the shell terminates by exec'ing another
process for example).
@@ -35994,30 +35994,30 @@ Shell startup process will continue with
Association list of environment variables to set for the Zsh session.
@item @code{zshenv} (default: @code{()}) (type: text-config)
-List of strings or gexps, which will be added to @file{.zshenv}. Used
+List of file-like objects, which will be added to @file{.zshenv}. Used
for setting user's shell environment variables. Must not contain
commands assuming the presence of tty or producing output. Will be read
always. Will be read before any other file in @env{ZDOTDIR}.
@item @code{zprofile} (default: @code{()}) (type: text-config)
-List of strings or gexps, which will be added to @file{.zprofile}. Used
+List of file-like objects, which will be added to @file{.zprofile}. Used
for executing user's commands at start of login shell (In most cases the
shell started on tty just after login). Will be read before
@file{.zlogin}.
@item @code{zshrc} (default: @code{()}) (type: text-config)
-List of strings or gexps, which will be added to @file{.zshrc}. Used
+List of file-like objects, which will be added to @file{.zshrc}. Used
for executing user's commands at start of interactive shell (The shell
for interactive usage started by typing @code{zsh} or by terminal app or
any other program).
@item @code{zlogin} (default: @code{()}) (type: text-config)
-List of strings or gexps, which will be added to @file{.zlogin}. Used
+List of file-like objects, which will be added to @file{.zlogin}. Used
for executing user's commands at the end of starting process of login
shell.
@item @code{zlogout} (default: @code{()}) (type: text-config)
-List of strings or gexps, which will be added to @file{.zlogout}. Used
+List of file-like objects, which will be added to @file{.zlogout}. Used
for executing user's commands at the exit of login shell. It won't be
read in some cases (if the shell terminates by exec'ing another process
for example).
diff --git a/doc/local.mk b/doc/local.mk
index 8340b75a87..fff11f8183 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -97,44 +97,29 @@ PO4A_PARAMS += -k 0 # produce an output even if the translation is not complete
PO4A_PARAMS += -f texinfo # texinfo format
# When a change to guix.texi occurs, it is not translated immediately.
-# Because @pxref and @xref commands are reference to a section by name, they
+# Because @pxref and @xref commands are references to sections by name, they
# should be translated. If a modification adds a reference to a section, this
# reference is not translated, which means it references a section that does not
# exist.
-# This command loops through the translated files looking for references. For
-# each of these references, it tries to find the translation and replaces the
-# reference name, even in untranslated strings.
-# The last sed is a multiline sed because some references span multiple lines.
define xref_command
-cat "$@.tmp" | egrep '@p?x?ref' -A1 | sed 'N;s|--\n||g;P;D' | sed 's|^| |g' | \
- tr -d '\012' | sed 's|\(@p\?x\?ref\)|\n\1|g' | egrep '@p?x?ref' | \
- sed 's|^.*@p\?x\?ref{\([^,}]*\).*$$|\1|g' | sort | uniq | while read e; do \
- if [ -n "$$e" ]; then \
- line=$$(grep -n "^msgid \"$$e\"" "$<" | cut -f1 --delimiter=":") ;\
- ((line++)) ;\
- if [ "$$line" != "1" ]; then \
- translation=$$(head -n "$$line" "$<" | tail -1 | grep msgstr | sed 's|msgstr "\([^"]*\)"|\1|') ;\
- if [ "$$translation" != "" ]; then \
- sed "N;s@\(p\?x\?ref\){$$(echo $$e | sed 's| |[\\n ]|g')\(,\|}\)@\1{$$translation\2@g;P;D" -i "$@.tmp" ;\
- fi ;\
- fi ;\
- fi ;\
-done
+$(top_srcdir)/pre-inst-env $(GUILE) --no-auto-compile \
+ "$(top_srcdir)/build-aux/convert-xref.scm" \
+ $@.tmp $<
endef
-$(srcdir)/%D%/guix.%.texi: po/doc/guix-manual.%.po $(srcdir)/%D%/contributing.%.texi
+$(srcdir)/%D%/guix.%.texi: po/doc/guix-manual.%.po $(srcdir)/%D%/contributing.%.texi guix/build/po.go
-$(AM_V_PO4A)$(PO4A_TRANSLATE) $(PO4A_PARAMS) -m "%D%/guix.texi" -p "$<" -l "$@.tmp"
-sed -i "s|guix\.info|$$(basename "$@" | sed 's|texi$$|info|')|" "$@.tmp"
-$(AM_V_POXREF)$(xref_command)
-mv "$@.tmp" "$@"
-$(srcdir)/%D%/guix-cookbook.%.texi: po/doc/guix-cookbook.%.po
+$(srcdir)/%D%/guix-cookbook.%.texi: po/doc/guix-cookbook.%.po guix/build/po.go
-$(AM_V_PO4A)$(PO4A_TRANSLATE) $(PO4A_PARAMS) -m "%D%/guix-cookbook.texi" -p "$<" -l "$@.tmp"
-sed -i "s|guix-cookbook\.info|$$(basename "$@" | sed 's|texi$$|info|')|" "$@.tmp"
-$(AM_V_POXREF)$(xref_command)
-mv "$@.tmp" "$@"
-$(srcdir)/%D%/contributing.%.texi: po/doc/guix-manual.%.po
+$(srcdir)/%D%/contributing.%.texi: po/doc/guix-manual.%.po guix/build/po.go
-$(AM_V_PO4A)$(PO4A_TRANSLATE) $(PO4A_PARAMS) -m "%D%/contributing.texi" -p "$<" -l "$@.tmp"
-$(AM_V_POXREF)$(xref_command)
-mv "$@.tmp" "$@"