summaryrefslogtreecommitdiff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-15 22:56:52 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-15 22:56:52 +0100
commit727afa3be86f24eaf16a014a73f4f21d8480a256 (patch)
treefaff94126628d754aba5a1a7a315dc5001abed38 /distro
parented9f9a7765ac5cf65e686986262802cdb918f4d7 (diff)
downloadguix-patches-727afa3be86f24eaf16a014a73f4f21d8480a256.tar
guix-patches-727afa3be86f24eaf16a014a73f4f21d8480a256.tar.gz
distro: Add patches forgotten in previous commits.
* distro/packages/patches/bigloo-gc-shebangs.patch, distro/packages/patches/emacs-configure-sh.patch, distro/packages/patches/procps-make-3.82.patch: New files. * Makefile.am (dist_patch_DATA): Add them.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/patches/bigloo-gc-shebangs.patch17
-rw-r--r--distro/packages/patches/emacs-configure-sh.patch14
-rw-r--r--distro/packages/patches/procps-make-3.82.patch14
3 files changed, 45 insertions, 0 deletions
diff --git a/distro/packages/patches/bigloo-gc-shebangs.patch b/distro/packages/patches/bigloo-gc-shebangs.patch
new file mode 100644
index 0000000000..07af261887
--- /dev/null
+++ b/distro/packages/patches/bigloo-gc-shebangs.patch
@@ -0,0 +1,17 @@
+Patch shebangs in source that gets unpacked by `configure'.
+
+--- bigloo3.9a/gc/install-gc-7.2d 2013-01-14 15:24:01.000000000 +0100
++++ bigloo3.9a/gc/install-gc-7.2d 2013-01-14 15:23:51.000000000 +0100
+@@ -29,9 +29,11 @@ fi
+ # untar the two versions of the GC
+ $tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
+ /bin/rm -rf "../gc/$gc"_fth
++find ../gc/gc-7.2 -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P bash`|g"
+ mv ../gc/gc-7.2 "../gc/$gc"_fth || (echo "mv gc-7.2 failed"; exit 1)
+
+ $tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
++find ../gc/gc-7.2 -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P bash`|g"
+ mv ../gc/gc-7.2 "../gc/$gc"
+
+ # general Bigloo patch
+
diff --git a/distro/packages/patches/emacs-configure-sh.patch b/distro/packages/patches/emacs-configure-sh.patch
new file mode 100644
index 0000000000..fd34d06ced
--- /dev/null
+++ b/distro/packages/patches/emacs-configure-sh.patch
@@ -0,0 +1,14 @@
+Make sure the right shell is used when creating src/epaths.h.
+
+--- emacs-24.2/configure 2013-01-13 17:01:53.000000000 +0100
++++ emacs-24.2/configure 2013-01-13 17:01:57.000000000 +0100
+@@ -24135,7 +24135,7 @@ done
+ ;;
+ "epaths":C)
+ echo creating src/epaths.h
+-${MAKE-make} epaths-force
++${MAKE-make} epaths-force SHELL="$CONFIG_SHELL"
+ ;;
+ "gdbinit":C)
+ if test ! -f src/.gdbinit && test -f $srcdir/src/.gdbinit; then
+
diff --git a/distro/packages/patches/procps-make-3.82.patch b/distro/packages/patches/procps-make-3.82.patch
new file mode 100644
index 0000000000..7bf53e2ccc
--- /dev/null
+++ b/distro/packages/patches/procps-make-3.82.patch
@@ -0,0 +1,14 @@
+Fix compilation with GNU Make 3.82 (patch from Nixpkgs).
+
+diff --git a/Makefile b/Makefile
+index 09fb3ed..59eba16 100644
+--- a/Makefile
++++ b/Makefile
+@@ -174,7 +174,7 @@ INSTALL := $(BINFILES) $(MANFILES)
+ # want this rule first, use := on ALL, and ALL not filled in yet
+ all: do_all
+
+--include */module.mk
++-include proc/module.mk ps/module.mk
+
+ do_all: $(ALL)