summaryrefslogtreecommitdiff
path: root/distro
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2012-11-21 12:24:14 +0000
committerLudovic Courtès <ludo@gnu.org>2012-11-21 17:02:17 +0100
commit0aa94f0ca400521ec1695b8c173ecdc7d9febea6 (patch)
treeae3fb8589ecb59a8b134b87d911ef2291f86dcfd /distro
parent3dc1970ddad359dda72899ec18dcba188c2b4414 (diff)
downloadguix-patches-0aa94f0ca400521ec1695b8c173ecdc7d9febea6.tar
guix-patches-0aa94f0ca400521ec1695b8c173ecdc7d9febea6.tar.gz
distro: Add GNU Ed.
* distro/packages/ed.scm: New file. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/ed.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/distro/packages/ed.scm b/distro/packages/ed.scm
new file mode 100644
index 0000000000..4b3ff76efc
--- /dev/null
+++ b/distro/packages/ed.scm
@@ -0,0 +1,52 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages ed)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public ed
+ (package
+ (name "ed")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnu/ed/ed-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "18gvhyhwpabmgv4lh21lg8vl3z7acdyhh2mr2kj9g75wksj39pcp"))))
+ (build-system gnu-build-system)
+ (arguments '(#:configure-flags '("CC=gcc")))
+ (home-page "http://www.gnu.org/software/ed/")
+ (synopsis
+ "GNU ed, an implementation of the standard Unix editor")
+ (description
+ "GNU ed is a line-oriented text editor. It is used to create,
+display, modify and otherwise manipulate text files, both
+interactively and via shell scripts. A restricted version of ed,
+red, can only edit files in the current directory and cannot
+execute shell commands. Ed is the \"standard\" text editor in the
+sense that it is the original editor for Unix, and thus widely
+available. For most purposes, however, it is superseded by
+full-screen editors such as GNU Emacs or GNU Moe.")
+ (license "GPLv3+")))