summaryrefslogtreecommitdiff
path: root/distro/packages/recutils.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-04 21:44:42 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-04 21:46:14 +0100
commit9d9e64508186e5f9efbe45302134cd709b25e47b (patch)
tree94e81999e707f8deaac3f8f047c64a3b21a5ea24 /distro/packages/recutils.scm
parent59b775cca97813a24e529171606e967b61e80877 (diff)
downloadguix-patches-9d9e64508186e5f9efbe45302134cd709b25e47b.tar
guix-patches-9d9e64508186e5f9efbe45302134cd709b25e47b.tar.gz
distro: Go for one module per package.
The alternative, which was to use one module per category, would probably not scale well. First, because many packages could fall into several categories (does GnuTLS go into "networking", "security", or "libraries"?). Second, because that could easily lead to circular dependencies among modules ("security" and "networking" depend on each other, etc.) * distro/packages/databases.scm: Rename to... * distro/packages/recutils.scm: ... this. * distro/packages/typesetting.scm: Rename to... * distro/packages/lout.scm: ... this. * Makefile.am (MODULES): Adjust accordingly. * po/POTFILES.in: Likewise.
Diffstat (limited to 'distro/packages/recutils.scm')
-rw-r--r--distro/packages/recutils.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/distro/packages/recutils.scm b/distro/packages/recutils.scm
new file mode 100644
index 0000000000..6221ee07c9
--- /dev/null
+++ b/distro/packages/recutils.scm
@@ -0,0 +1,52 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages recutils)
+ #:use-module (distro)
+ #:use-module (guix packages)
+ #:use-module (guix http)
+ #:use-module (guix utils)
+ #:use-module (guix build-system gnu))
+
+(define-public recutils
+ (package
+ (name "recutils")
+ (version "1.5")
+ (source (origin
+ (method http-fetch)
+ (uri (string-append "http://ftp.gnu.org/gnu/recutils/recutils-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1v2xzwwwhc5j5kmvg4sv6baxjpsfqh8ln7ilv4mgb1408rs7xmky"))))
+ (build-system gnu-build-system)
+ (inputs `(("curl" ,(nixpkgs-derivation "curl"))
+ ("emacs" ,(nixpkgs-derivation "emacs"))
+ ("check" ,(nixpkgs-derivation "check"))
+ ("bc" ,(nixpkgs-derivation "bc"))
+ ("patch/gets"
+ ,(search-patch "diffutils-gets-undeclared.patch"))))
+ (arguments `(#:patches (list (assoc-ref %build-inputs "patch/gets"))))
+ (synopsis "GNU recutils, tools and libraries to access human-editable,
+text-based databases")
+ (description
+ "GNU recutils is a set of tools and libraries to access human-editable,
+text-based databases called recfiles. The data is stored as a sequence of
+records, each record containing an arbitrary number of named fields.")
+ (license "GPLv3+")
+ (home-page "http://www.gnu.org/software/recutils/")))