summaryrefslogtreecommitdiff
path: root/distro/packages/readline.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
commitc089511288820cfb3efc5295e572be24aa83f068 (patch)
treeece62d1d06ee146feb59f60fe5c4d307542205cc /distro/packages/readline.scm
parent8722e80e82f6b2ca326b20a4b3179ed25115ce4f (diff)
downloadguix-patches-c089511288820cfb3efc5295e572be24aa83f068.tar
guix-patches-c089511288820cfb3efc5295e572be24aa83f068.tar.gz
build-system/gnu: Patch shebangs in all the source; patch SHELL in makefiles.
* guix/build/utils.scm (call-with-ascii-input-file): New procedure. (patch-shebang): Use it. (patch-makefile-SHELL): New procedure. * guix/build/gnu-build-system.scm (patch-source-shebangs): Patch all the files, not just executables; remove `po/Makefile.in.in' patching. (patch-generated-files): Rename to... (patch-generated-file-shebangs): ... this. Patch executables and makefiles. (%standard-phases): Adjust accordingly. * distro/packages/autotools.scm (libtool): Remove call to `patch-shebang'. * distro/packages/base.scm (gcc-4.7): Likewise. (guile-final): Remove hack to skip `test-command-line-encoding2'. * distro/packages/bash.scm (bash): Remove `pre-configure-phase'. * distro/packages/readline.scm (readline): Likewise. * distro/packages/ncurses.scm (ncurses): Remove `pre-install-phase'.
Diffstat (limited to 'distro/packages/readline.scm')
-rw-r--r--distro/packages/readline.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/distro/packages/readline.scm b/distro/packages/readline.scm
index bf542e90b5..8e2a4cbb5d 100644
--- a/distro/packages/readline.scm
+++ b/distro/packages/readline.scm
@@ -36,14 +36,7 @@
(for-each (lambda (f) (chmod f #o755))
(find-files lib "\\.so"))
(for-each (lambda (f) (chmod f #o644))
- (find-files lib "\\.a")))))
- (pre-configure-phase
- '(lambda* (#:key inputs #:allow-other-keys)
- ;; Use the right shell for makefiles.
- (let ((bash (assoc-ref inputs "bash")))
- (substitute* "configure"
- (("^MAKE_SHELL=.*")
- (format #f "MAKE_SHELL=~a/bin/bash" bash)))))))
+ (find-files lib "\\.a"))))))
(package
(name "readline")
(version "6.2")
@@ -69,10 +62,7 @@
#:phases (alist-cons-after
'install 'post-install
,post-install-phase
- (alist-cons-before
- 'configure 'pre-configure
- ,pre-configure-phase
- %standard-phases))))
+ %standard-phases)))
(synopsis "GNU Readline, a library for interactive line editing")
(description
"The GNU Readline library provides a set of functions for use by